Bug 862866 - update to askbot 0.7.43+
update to askbot 0.7.43+
Status: CLOSED DUPLICATE of bug 915390
Product: Fedora EPEL
Classification: Fedora
Component: askbot (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 15:13 EDT by Matthew Miller
Modified: 2013-02-25 12:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 12:41:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-03 15:13:25 EDT
See: https://fedorahosted.org/fedora-infrastructure/ticket/3496


Problem
=======

We have a lot of spam in Ask Fedora. This is bad because:

* spam is evil
* it makes the site look unmaintained
* it buries real questions and answers 

Analysis
========

Askbot 0.7.43 introduces a "basic moderation" feature (​http://askbot.org/doc/moderation.html) which will help mitigate the problem by allowing site members in good standing to flag and, given enough reputation, even delete spam posts.

Enhancement recommendation
==========================

Please update to that version.
Comment 1 Matthew Miller 2012-10-03 15:15:22 EDT
One concern is that apparently upgrading Askbot involves running a database sync command, the changelog for 0.7.40 includes "New data models!!!", which makes me cautious about introducting an upgrade to EPEL.

http://askbot.org/doc/initialize-database-tables.html?highlight=upgrade

http://askbot.org/doc/changelog.html
Comment 2 Matthias Runge 2012-12-14 04:25:55 EST
I'd recommend to wait, until askbot supports Django-1.4. Django-1.3 is being deprecated by upstream, when django-1.5 is released. That'll be around Christmas 2012.
Comment 3 Rahul Sundaram 2013-02-05 18:26:49 EST
@Matthias, do you have info on the current status?
Comment 4 Matthias Runge 2013-02-06 03:12:07 EST
Django-1.5 is expected in two weeks or so;
we have Django14 and django (version 1.3) in EPEL.

The changelog lists, Django-1.4 is supported now; I don't know, if there's a migration between different database versions. Also, I think dependencies have changed. Just updating in EPEL will break peoples installations.
Comment 5 Rahul Sundaram 2013-02-25 12:41:18 EST

*** This bug has been marked as a duplicate of bug 915390 ***

Note You need to log in before you can comment on or make changes to this bug.