Bug 862924 - RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 17589662904832 and this is thread id 17589767434752
RepoError: SQLite objects created in a thread can only be used in that same t...
Status: CLOSED DUPLICATE of bug 851114
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:2913d6183bcb019af6b613e08b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 18:19 EDT by Mark Hamzy
Modified: 2013-01-10 01:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 18:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (181.56 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: product (6 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: type (9 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: storage.log (71.56 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: version (7 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: environ (813 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: anaconda.log (2.19 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: syslog (39.59 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: packaging.log (3.70 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: cmdline_file (184 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: release (24 bytes, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details
File: program.log (32.55 KB, text/plain)
2012-10-03 18:19 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-10-03 18:19:09 EDT
Description of problem:
Default package selection of Gnome Desktop failed, so I selected Minimal and Standard.

Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.ppc64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 55, in newFunc
:    raise Errors.RepoError, str(e)
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 266, in __getattr__
:    (self.pkgId,)).fetchone()
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 347, in returnIdSum
:    return (self.checksum_type, self.pkgId)
:  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 675, in futureRpmDBVersion
:    csum = pkg.returnIdSum()
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6342, in save_ts
:    msg += "%s:%s\n" % ('installed', self.tsInfo.futureRpmDBVersion())
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1273, in buildTransaction
:    self.save_ts(auto=True)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1083, in checkSoftwareSelection
:    (code, msgs) = self._yum.buildTransaction(unfinished_transactions_check=False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 87, in checkSoftwareSelection
:    self.payload.checkSoftwareSelection()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 17589662904832 and this is thread id 17589767434752
Comment 1 Mark Hamzy 2012-10-03 18:19:11 EDT
Created attachment 621175 [details]
File: anaconda-tb
Comment 2 Mark Hamzy 2012-10-03 18:19:13 EDT
Created attachment 621176 [details]
File: product
Comment 3 Mark Hamzy 2012-10-03 18:19:15 EDT
Created attachment 621177 [details]
File: type
Comment 4 Mark Hamzy 2012-10-03 18:19:16 EDT
Created attachment 621178 [details]
File: storage.log
Comment 5 Mark Hamzy 2012-10-03 18:19:18 EDT
Created attachment 621179 [details]
File: version
Comment 6 Mark Hamzy 2012-10-03 18:19:19 EDT
Created attachment 621180 [details]
File: environ
Comment 7 Mark Hamzy 2012-10-03 18:19:21 EDT
Created attachment 621181 [details]
File: anaconda.log
Comment 8 Mark Hamzy 2012-10-03 18:19:23 EDT
Created attachment 621182 [details]
File: syslog
Comment 9 Mark Hamzy 2012-10-03 18:19:24 EDT
Created attachment 621183 [details]
File: hashmarkername
Comment 10 Mark Hamzy 2012-10-03 18:19:26 EDT
Created attachment 621184 [details]
File: packaging.log
Comment 11 Mark Hamzy 2012-10-03 18:19:27 EDT
Created attachment 621185 [details]
File: cmdline_file
Comment 12 Mark Hamzy 2012-10-03 18:19:29 EDT
Created attachment 621186 [details]
File: release
Comment 13 Mark Hamzy 2012-10-03 18:19:30 EDT
Created attachment 621187 [details]
File: program.log
Comment 14 Jesse Keating 2012-10-03 18:31:17 EDT
I think it's a duplicate of this.

*** This bug has been marked as a duplicate of bug 851114 ***

Note You need to log in before you can comment on or make changes to this bug.