Bug 851114 - RepoError: SQLite objects created in a thread can only be used in that same thread
RepoError: SQLite objects created in a thread can only be used in that same t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 854426 861140 862924 862941 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-23 05:46 EDT by Jan Sedlák
Modified: 2016-08-08 09:32 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 17:20:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda tb log (285.71 KB, text/plain)
2012-08-23 05:46 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2012-08-23 05:46:29 EDT
Created attachment 606493 [details]
anaconda tb log

Description of problem:
I have selected "Basic installation", then partitioned my disk and when I came back into installation menu, software selection showed "Error checking software selection". So I have clicked it, selected "Base" again and returned back. Whole GUI freezed. In /tmp was anaconda-tb log saying "RepoError: SQLite objects created in a thread can only be used in that same thread.". This happens only if desired software target has broken dependency (currently Base and Gnome). See attached log.

How reproducible:
not sure

Steps to Reproduce:
1. Have broken dependency in repository
2. Use installation from repository
3. Select software group that has broken dependency (currently Base and Gnome)
4. Wait until it checks dependencies, showing "error checking software selection"
5. Do something else (e.g. disk partitioning)
6. Return back to main installation menu
7. Click on "Software selection" again, select Base or Gnome again, return to menu.
  
Actual results:
It freezes

Expected results:
It shouldn't freeze
Comment 1 Chris Lumens 2012-08-23 16:25:35 EDT
Dave was talking about having some missing yum locks, which I think would fix this up too.
Comment 2 Chris Lumens 2012-09-05 11:38:37 EDT
*** Bug 854426 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2012-09-28 17:31:46 EDT
I just hit this simply by switching from GNOME to KDE in a test install from smoke3 (the latest smoketest image, with 18.10). I don't think any broken deps were involved. Marking as a potential Beta blocker.
Comment 4 Jens Petersen 2012-09-30 05:49:27 EDT
Yes seems to happen for any change of package environment.
Comment 5 Jens Petersen 2012-09-30 05:55:10 EDT
*** Bug 861140 has been marked as a duplicate of this bug. ***
Comment 6 Tim Flink 2012-10-02 16:18:32 EDT
I found depsolving issues when attempting to install from smoketest4 (anaconda-18.11-1) which are due to a missing package on the DVD.

I tried to work around the issue by removing the package in the error dialog but there were still depsolving issues and couldn't install. When I tried to select a different DE package set (XFCE, I think) I got this crash from anaconda.

Will try to reproduce.


Package: anaconda-18.11
OS Release: Fedora release 18
Comment 7 Martin Banas 2012-10-03 05:56:48 EDT
1. Start graphical installation of Fedora
2. Proceed to main hub "Installation summary"
3. Select "Software selection"
4. Select minimal package set
5. go back
6. Traceback


Package: anaconda-18.11
OS Release: Fedora release 18-Beta-TC1
Comment 8 David Jaša 2012-10-03 09:27:12 EDT
This bug occured after I finished manual partitioning and hit Continue button.

The partitioning reused existing GPT table with just GPT boot, swap and / partitions.


Package: anaconda-18.11
OS Release: Fedora release 18-Beta-TC1
Comment 9 Adam Williamson 2012-10-03 14:40:18 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . Accepted as a blocker per criterion "The installer must be able to install each of the release blocking desktops, as well as the minimal package set, with each supported installation method". There may be a slight timing element to this - it might not happen _every_ time you try and pick a different package set - but it certainly happens on a lot of such tries, enough for us to accept it as a blocker.
Comment 10 Jesse Keating 2012-10-03 18:31:17 EDT
*** Bug 862924 has been marked as a duplicate of this bug. ***
Comment 11 Reartes Guillermo 2012-10-03 21:43:17 EDT
These seems like duplicates.
 
Bug 853549 - RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 139746785892096 and this is thread id 139746689693440

---

Bug 862941 - RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 140116443670272 and this is thread id 140116778125056
Comment 12 Chris Lumens 2012-10-04 10:32:55 EDT
*** Bug 862941 has been marked as a duplicate of this bug. ***
Comment 13 Reartes Guillermo 2012-10-04 23:47:49 EDT
selected xfce

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 14 John Reiser 2012-10-06 10:39:58 EDT
Boot Fedora 18 Beta TC2 netinst.iso from DVD.  Default English. Auto-select Closest Mirror and Gnome Desktop.  Change timezone to America-Los Angeles.  Change Software Selection to XFCE, click Done.  BANG!

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 15 John Reiser 2012-10-06 11:35:53 EDT
Works for me using anaconda-18.13 on DVD which I composed myself using pungi.
Comment 16 Ian Pilcher 2012-10-06 19:06:25 EDT
Made the mistake of trying to install F18 Beta TC2

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 17 Daniel Greeley 2012-10-06 21:03:20 EDT
Happens on TC2 when changing the DE from Gnome to Xfce.
Comment 18 Christoph Wickert 2012-10-07 16:35:52 EDT
Just press ALT+D and anaconda will crash.

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 19 Christoph Wickert 2012-10-07 16:46:03 EDT
(In reply to comment #18)
> Just press ALT+D and anaconda will crash.

I mean, press ALT+D when you are in the package selection. ALT+D should bring you back to the main hub and even if one doesn't change anything in the package spoke, anaconda crashes reproducibly.
Comment 20 Alex Lancaster 2012-10-08 00:51:41 EDT
Tried selecting some additional packages

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 21 Reartes Guillermo 2012-10-08 14:40:16 EDT
F18b TC2:

Options that lead to this bug-report issue:

* Developement and Creative Workstation
* KDE Desktop
* XFCE Desktop
* LXDE Desktop

Selecting any of these does NOT lead to this  bug-report issue:

* Sugar Desktop Environment
* Web Server
* Infrastructure Server
* Basic x windows
* Minimal

Tried the ALT+D method (boot, enter software selection, ALT+D) and it did not lead to the issue, GNOME was automatically re-selected.
Comment 22 Reartes Guillermo 2012-10-08 15:46:52 EDT
I tried selecting a different installation source: CLOSEST MIRROR and 
then i tried to select "KDE Desktop".

The result is different, instead of generating this bug-report issue,
it just says: "error checking software selection".

Selecting XFCE, LXDE appears to work correctly with closest mirror.

These also remained working ok: 

* Sugar Desktop Environment
* Web Server
* Infrastructure Server
* Basic x windows
* Minimal

And with "Development and Creative Workstation" the guest
seems to froze (happened two times), alt+tab does not work
nor send_key_alt+f2 in virt-manager, so not i am not able
to switch to another vt

do i open another bug-report for this?
Comment 23 Daniel Belton 2012-10-08 17:46:00 EDT
Installing F18 TC2, after selecting package groups, this error occurred

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 24 Fedora Update System 2012-10-08 20:21:46 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 25 Fedora Update System 2012-10-09 13:21:27 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 26 Jan Sedlák 2012-10-15 08:28:25 EDT
I have tried all "how to reproduce" instructions and everything was OK.
Comment 27 Adam Williamson 2012-10-18 17:20:17 EDT
18.14 went stable, so we can close this.

Note You need to log in before you can comment on or make changes to this bug.