This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 862941 - RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 140116443670272 and this is thread id 140116778125056
RepoError: SQLite objects created in a thread can only be used in that same t...
Status: CLOSED DUPLICATE of bug 851114
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3645719e8e726a9ce3457f4113f...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-03 21:32 EDT by Reartes Guillermo
Modified: 2012-10-04 10:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 10:32:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (200.00 KB, text/plain)
2012-10-03 21:32 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-03 21:32 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-03 21:32 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-03 21:32 EDT, Reartes Guillermo
no flags Details
File: storage.log (68.44 KB, text/plain)
2012-10-03 21:32 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: environ (788 bytes, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (1.85 KB, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: syslog (65.61 KB, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: packaging.log (3.62 KB, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (113 bytes, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details
File: program.log (27.98 KB, text/plain)
2012-10-03 21:33 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-03 21:32:39 EDT
Description of problem:
all ok until i selected KDE Desktop and leave software selection

Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 55, in newFunc
:    raise Errors.RepoError, str(e)
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 392, in returnPrco
:    cur = self._sql_MD('primary', sql, (self.pkgKey,))
:  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 651, in returnPrcoNames
:    data = [n for (n, f, v) in self.returnPrco(prcotype)]
:  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 676, in <lambda>
:    provides_names = property(fget=lambda self: self.returnPrcoNames('provides'))
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 237, in allowedMultipleInstalls
:    for prov in po.provides_names:
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4525, in install
:    if not self.allowedMultipleInstalls(po):
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 86, in __call__
:    return self.ayum.install(*args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 306, in add
:    for condtxmbr in self.install_method(po=pkg):
:  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 458, in addInstall
:    self.add(txmbr)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4567, in install
:    txmbr = self.tsInfo.addInstall(po)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 717, in _requiringFromTransaction
:    txmbrs = self.install(best, provides_for=reqtuple)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 338, in _processReq
:    CheckDeps, missingdep = self._requiringFromTransaction(po, requirement, errormsgs)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 1018, in _resolveRequires
:    (checkdep, missing, errormsgs) = self._processReq(po, dep)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 873, in resolveDeps
:    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1120, in buildTransaction
:    (rescode, restring) = self.resolveDeps()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1083, in checkSoftwareSelection
:    (code, msgs) = self._yum.buildTransaction(unfinished_transactions_check=False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 87, in checkSoftwareSelection
:    self.payload.checkSoftwareSelection()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:RepoError: SQLite objects created in a thread can only be used in that same thread.The object was created in thread id 140116443670272 and this is thread id 140116778125056
Comment 1 Reartes Guillermo 2012-10-03 21:32:48 EDT
Created attachment 621210 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-03 21:32:50 EDT
Created attachment 621211 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-03 21:32:52 EDT
Created attachment 621212 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-03 21:32:54 EDT
Created attachment 621213 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-03 21:32:58 EDT
Created attachment 621214 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-03 21:33:00 EDT
Created attachment 621215 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-03 21:33:02 EDT
Created attachment 621216 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-03 21:33:05 EDT
Created attachment 621217 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-03 21:33:08 EDT
Created attachment 621218 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-03 21:33:11 EDT
Created attachment 621219 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-03 21:33:13 EDT
Created attachment 621220 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-03 21:33:16 EDT
Created attachment 621221 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-03 21:33:18 EDT
Created attachment 621222 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-03 21:33:21 EDT
Created attachment 621223 [details]
File: program.log
Comment 15 Chris Lumens 2012-10-04 10:32:55 EDT

*** This bug has been marked as a duplicate of bug 851114 ***

Note You need to log in before you can comment on or make changes to this bug.