This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 862953 - SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the directory hpfax-pipe-10.
SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6aac09f1070b72b23213b15244f...
:
: 862954 862955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 22:52 EDT by Tony
Modified: 2012-12-20 10:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:38:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 22:52 EDT, Tony
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 22:52 EDT, Tony
no flags Details

  None (edit)
Description Tony 2012-10-03 22:52:45 EDT
Description of problem:
When attempting to print to fax from Libreoffice Write on HP fax / printer C7280.
Happens every time I try to print to fax.


Additional info:
libreport version: 2.0.14
kernel:         3.5.4-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the directory hpfax-pipe-10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed remove_name access on the hpfax-pipe-10 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep hpfax /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:hplip_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:var_log_t:s0
:Target Objects                hpfax-pipe-10 [ dir ]
:Source                        hpfax
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-7.2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep
:                              26 21:58:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-04 15:14:49 NZDT
:Last Seen                     2012-10-04 15:14:49 NZDT
:Local ID                      d7ba5b55-1bf5-4b48-9294-5ba7bdbadfb8
:
:Raw Audit Messages
:type=AVC msg=audit(1349316889.108:105): avc:  denied  { remove_name } for  pid=2113 comm="hpfax" name="hpfax-pipe-10" dev="sda5" ino=915545 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349316889.108:105): avc:  denied  { unlink } for  pid=2113 comm="hpfax" name="hpfax-pipe-10" dev="sda5" ino=915545 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349316889.108:105): arch=x86_64 syscall=unlink success=yes exit=0 a0=1850120 a1=ffffffff a2=35c8bb39c8 a3=20 items=0 ppid=698 pid=2113 auid=4294967295 uid=0 gid=7 euid=0 suid=0 fsuid=0 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=hpfax exe=/usr/bin/python2.7 subj=system_u:system_r:hplip_t:s0-s0:c0.c1023 key=(null)
:
:Hash: hpfax,hplip_t,var_log_t,dir,remove_name
:
:audit2allow
:
:#============= hplip_t ==============
:allow hplip_t var_log_t:dir remove_name;
:allow hplip_t var_log_t:fifo_file unlink;
:
:audit2allow -R
:
:#============= hplip_t ==============
:allow hplip_t var_log_t:dir remove_name;
:allow hplip_t var_log_t:fifo_file unlink;
:
Comment 1 Tony 2012-10-03 22:52:49 EDT
Created attachment 621268 [details]
File: type
Comment 2 Tony 2012-10-03 22:52:50 EDT
Created attachment 621270 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-04 04:01:54 EDT
*** Bug 862954 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-04 04:02:02 EDT
*** Bug 862955 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-10-04 04:02:33 EDT
Fixed in selinux-policy-3.10.0-152.fc17.noarch
Comment 6 Fedora Update System 2012-10-08 10:06:42 EDT
selinux-policy-3.10.0-153.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-153.fc17
Comment 7 Fedora Update System 2012-10-08 17:57:39 EDT
Package selinux-policy-3.10.0-153.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-153.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15652/selinux-policy-3.10.0-153.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-20 10:38:55 EST
selinux-policy-3.10.0-153.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.