Bug 862955 - SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/log/hp.
SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directo...
Status: CLOSED DUPLICATE of bug 862953
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4c8e7478f171dbdabc13c1ed45e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 22:55 EDT by Tony
Modified: 2012-10-04 04:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 04:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-03 22:55 EDT, Tony
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-03 22:55 EDT, Tony
no flags Details

  None (edit)
Description Tony 2012-10-03 22:55:48 EDT
Description of problem:
When attempting to print to fax from Libreoffice Write on HP fax / printer C7280.
Happens every time I try to print to fax.


Additional info:
libreport version: 2.0.14
kernel:         3.5.4-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/log/hp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed write access on the hp directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep hpfax /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:hplip_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:var_log_t:s0
:Target Objects                /var/log/hp [ dir ]
:Source                        hpfax
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-7.2.fc17.x86_64
:Target RPM Packages           hplip-3.12.6-1.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-2.fc17.x86_64 #1 SMP Wed Sep
:                              26 21:58:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-04 15:14:49 NZDT
:Last Seen                     2012-10-04 15:14:49 NZDT
:Local ID                      155b6b9f-abf0-40f4-9d69-f65001718e60
:
:Raw Audit Messages
:type=AVC msg=audit(1349316889.107:103): avc:  denied  { write } for  pid=2113 comm="hpfax" name="hp" dev="sda5" ino=915293 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349316889.107:103): avc:  denied  { add_name } for  pid=2113 comm="hpfax" name="hpfax-pipe-10" scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349316889.107:103): avc:  denied  { create } for  pid=2113 comm="hpfax" name="hpfax-pipe-10" scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349316889.107:103): arch=x86_64 syscall=mknod success=yes exit=0 a0=1bd4694 a1=11b6 a2=0 a3=1 items=0 ppid=698 pid=2113 auid=4294967295 uid=0 gid=7 euid=0 suid=0 fsuid=0 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=hpfax exe=/usr/bin/python2.7 subj=system_u:system_r:hplip_t:s0-s0:c0.c1023 key=(null)
:
:Hash: hpfax,hplip_t,var_log_t,dir,write
:
:audit2allow
:
:#============= hplip_t ==============
:#!!!! The source type 'hplip_t' can write to a 'dir' of the following types:
:# hplip_tmp_t, var_run_t, hplip_var_lib_t, hplip_var_run_t, print_spool_t, tmp_t, cupsd_tmp_t, root_t
:
:allow hplip_t var_log_t:dir { write add_name };
:allow hplip_t var_log_t:fifo_file create;
:
:audit2allow -R
:
:#============= hplip_t ==============
:#!!!! The source type 'hplip_t' can write to a 'dir' of the following types:
:# hplip_tmp_t, var_run_t, hplip_var_lib_t, hplip_var_run_t, print_spool_t, tmp_t, cupsd_tmp_t, root_t
:
:allow hplip_t var_log_t:dir { write add_name };
:allow hplip_t var_log_t:fifo_file create;
:
Comment 1 Tony 2012-10-03 22:55:51 EDT
Created attachment 621279 [details]
File: type
Comment 2 Tony 2012-10-03 22:55:53 EDT
Created attachment 621280 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-04 04:02:02 EDT

*** This bug has been marked as a duplicate of bug 862953 ***

Note You need to log in before you can comment on or make changes to this bug.