Bug 863045 - ValueError: Cannot remove extended partition sda4. Logical partitions present.
ValueError: Cannot remove extended partition sda4. Logical partitions present.
Status: CLOSED DUPLICATE of bug 862971
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
ppc64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:a1140655f1feaa252a0401923f2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 06:07 EDT by Martin Banas
Modified: 2012-10-05 10:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 10:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (263.12 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: product (24 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: type (9 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: storage.log (145.57 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: version (3 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: environ (901 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: anaconda.log (16.21 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: syslog (37.75 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: packaging.log (1.66 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: cmdline_file (194 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: release (58 bytes, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details
File: program.log (33.06 KB, text/plain)
2012-10-04 06:07 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2012-10-04 06:07:20 EDT
Description of problem:
Steps to reproduce:

1. Start installation on PPC64, where there's already a partitioning layout from previous installation
2. In partitioning step, remove /, /boot and swap partition
3. In unknown "tab", remove PPC PReP partition (there's probably a bug, because the space is marked as Unknown, not removed
4. Let anaconda create the partitioning for you (There's a link for it)
5. Anaconda doesn't create a PReP partition, so create it manually:
6. First resize the /boot partition (500MB -> 495MB)
7. After this step anaconda crashes.


Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.27.el7.ppc64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 385, in _removeDevice
:    "Logical partitions present." % dev.name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 425, in registerAction
:    self._removeDevice(action.device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1219, in destroyDevice
:    self.devicetree.registerAction(action)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 692, in updateExtendedPartitions
:    storage.destroyDevice(part)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 790, in doPartitioning
:    updateExtendedPartitions(storage, disks)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1913, in allocatePartitions
:    doPartitioning(self)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3198, in post_create
:    self.storage.allocatePartitions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2086, in newDevice
:    factory.post_create()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 974, in _save_right_side
:    raid_level=raid_level)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1534, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 188, in _onSelectorClicked
:    cb(selector)
:ValueError: Cannot remove extended partition sda4.  Logical partitions present.
Comment 1 Martin Banas 2012-10-04 06:07:22 EDT
Created attachment 621526 [details]
File: anaconda-tb
Comment 2 Martin Banas 2012-10-04 06:07:23 EDT
Created attachment 621527 [details]
File: product
Comment 3 Martin Banas 2012-10-04 06:07:25 EDT
Created attachment 621528 [details]
File: type
Comment 4 Martin Banas 2012-10-04 06:07:27 EDT
Created attachment 621529 [details]
File: storage.log
Comment 5 Martin Banas 2012-10-04 06:07:28 EDT
Created attachment 621530 [details]
File: version
Comment 6 Martin Banas 2012-10-04 06:07:30 EDT
Created attachment 621531 [details]
File: environ
Comment 7 Martin Banas 2012-10-04 06:07:31 EDT
Created attachment 621532 [details]
File: anaconda.log
Comment 8 Martin Banas 2012-10-04 06:07:33 EDT
Created attachment 621533 [details]
File: syslog
Comment 9 Martin Banas 2012-10-04 06:07:35 EDT
Created attachment 621534 [details]
File: hashmarkername
Comment 10 Martin Banas 2012-10-04 06:07:36 EDT
Created attachment 621535 [details]
File: packaging.log
Comment 11 Martin Banas 2012-10-04 06:07:38 EDT
Created attachment 621536 [details]
File: cmdline_file
Comment 12 Martin Banas 2012-10-04 06:07:39 EDT
Created attachment 621537 [details]
File: release
Comment 13 Martin Banas 2012-10-04 06:07:41 EDT
Created attachment 621538 [details]
File: program.log
Comment 14 Chris Lumens 2012-10-05 10:43:53 EDT
We'll work this from the Fedora side and get it committed there, so let's track it in the already open bug.

*** This bug has been marked as a duplicate of bug 862971 ***

Note You need to log in before you can comment on or make changes to this bug.