Bug 862971 - ValueError: Cannot remove extended partition sda4. Logical partitions present.
ValueError: Cannot remove extended partition sda4. Logical partitions present.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8590c86f21c9cc0a757a8426043...
:
: 863045 863354 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-04 00:20 EDT by Mark Hamzy
Modified: 2012-10-22 19:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 19:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (188.70 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: product (6 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: type (9 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: environ (813 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: storage.log (77.39 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: version (2 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: program.log (32.52 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: anaconda.log (2.52 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: syslog (40.66 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: packaging.log (3.42 KB, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: cmdline_file (184 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: release (24 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details
File: description (680 bytes, text/plain)
2012-10-04 00:20 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-10-04 00:20:33 EDT
Version-Release number of selected component:
anaconda-18.12

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-2.fc18.ppc64
Comment 1 Mark Hamzy 2012-10-04 00:20:36 EDT
Created attachment 621308 [details]
File: anaconda-tb
Comment 2 Mark Hamzy 2012-10-04 00:20:38 EDT
Created attachment 621309 [details]
File: product
Comment 3 Mark Hamzy 2012-10-04 00:20:39 EDT
Created attachment 621310 [details]
File: type
Comment 4 Mark Hamzy 2012-10-04 00:20:41 EDT
Created attachment 621311 [details]
File: environ
Comment 5 Mark Hamzy 2012-10-04 00:20:42 EDT
Created attachment 621312 [details]
File: storage.log
Comment 6 Mark Hamzy 2012-10-04 00:20:44 EDT
Created attachment 621313 [details]
File: version
Comment 7 Mark Hamzy 2012-10-04 00:20:46 EDT
Created attachment 621314 [details]
File: program.log
Comment 8 Mark Hamzy 2012-10-04 00:20:47 EDT
Created attachment 621315 [details]
File: anaconda.log
Comment 9 Mark Hamzy 2012-10-04 00:20:49 EDT
Created attachment 621316 [details]
File: syslog
Comment 10 Mark Hamzy 2012-10-04 00:20:50 EDT
Created attachment 621317 [details]
File: hashmarkername
Comment 11 Mark Hamzy 2012-10-04 00:20:52 EDT
Created attachment 621318 [details]
File: packaging.log
Comment 12 Mark Hamzy 2012-10-04 00:20:53 EDT
Created attachment 621319 [details]
File: cmdline_file
Comment 13 Mark Hamzy 2012-10-04 00:20:55 EDT
Created attachment 621320 [details]
File: release
Comment 14 Mark Hamzy 2012-10-04 00:20:57 EDT
Created attachment 621321 [details]
File: description
Comment 15 satellitgo 2012-10-04 16:12:01 EDT
no automatic partitioning offered in HD selection of f18-Beta-TC2-x86_64 CD when I try to shrink (by deleting existing partitions) Anaconda 18-12 crashes

Package: anaconda-18.12
Architecture: x86_64
OS Release: Fedora release 18-Beta-TC2
Comment 16 Jens Petersen 2012-10-05 03:51:30 EDT
Tried to recover space on my HD by deleting all existing partitions.

I assume there will be a "please just use the whole disk" option in F18.


Package: anaconda-18.12-1.fc18.x86_64
Architecture: x86_64
OS Release: Fedora release 18
Comment 17 Jens Petersen 2012-10-05 04:20:40 EDT
*** Bug 863354 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2012-10-05 10:43:53 EDT
*** Bug 863045 has been marked as a duplicate of this bug. ***
Comment 19 Kamil Páral 2012-10-08 05:42:22 EDT
I tried to remove all existing partitions to "reclaim space".

Package: anaconda-18.12-1.fc18.x86_64
OS Release: Fedora release 18
Comment 20 Jan Sedlák 2012-10-08 09:40:17 EDT
I tried to setup partitions in F18 Beta TC2, XFCE live desktop. It said that I have full disk and whether I want to redeem space. I have selected to remove all existing partitions, then this error showed up.

Package: anaconda-18.12-1.fc18.x86_64
OS Release: Fedora release 18
Comment 21 Fedora Update System 2012-10-08 20:21:40 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 22 Fedora Update System 2012-10-09 13:21:18 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 23 Adam Williamson 2012-10-10 14:06:58 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Accepted as a blocker per Beta criterion "The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types"
Comment 24 Kamil Páral 2012-10-16 10:25:46 EDT
This seems to be fixed with F18 Beta TC4. I created 3 primary partitions, then extended and 2 logical partitions inside. I marked all of them to be reclaimed, everything worked.
Comment 25 Adam Williamson 2012-10-18 17:26:03 EDT
Can anyone else confirm this is fixed in TC3 or later? It'd be nice to have one more confirmation before closing.
Comment 26 Jens Petersen 2012-10-19 04:23:34 EDT
I think it is, but bug 863348 is still open...
Comment 27 Jens Petersen 2012-10-19 06:14:07 EDT
Testing this now again, as far as I can tell anaconda no longer lists sda4
in its UI so I guess the problem may not be possible any more.

Anyway with F18b-smoke11 (anaconda-18-18) I am now able to reclaim space
by removing all partitions and then install with auto-partitioning.
Comment 28 Adam Williamson 2012-10-22 19:25:19 EDT
OK, let's call this fixed then. Probably was fixed in 18.14, and 18.19 is on its way to stable anyway.

Note You need to log in before you can comment on or make changes to this bug.