Bug 863055 - Image import is not working with "Cloud Resource Provider's Image ID "
Image import is not working with "Cloud Resource Provider's Image ID "
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 06:41 EDT by Rehana
Modified: 2012-12-04 10:23 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
The image detail page previously showed the providers image UUID as the "Cloud Resource Provider's Image ID". This is caused confusion when importing existing images. This update removes the UUID value and replaces the Cloud providers image identifier.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:23:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ID (32.11 KB, image/png)
2012-10-04 07:05 EDT, Rehana
no flags Details
import_UUID (34.36 KB, image/png)
2012-10-04 07:06 EDT, Rehana
no flags Details
afr_imp (53.57 KB, image/png)
2012-10-04 07:06 EDT, Rehana
no flags Details
img_detail (70.09 KB, image/png)
2012-10-04 07:08 EDT, Rehana
no flags Details
image id (62.54 KB, image/png)
2012-10-10 20:13 EDT, Shveta
no flags Details

  None (edit)
Description Rehana 2012-10-04 06:41:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Its a related bug of https://bugzilla.redhat.com/show_bug.cgi?id=857899
2.Tried to import image using "Cloud Resource Provider's Image ID" 
3.Its says "The requested image was not found on the Cloud Resource Provider"
4.But when i tried to import with the UUID, the image import worked
  
Actual results:


Expected results:
NOT sure the image import should work with Image uuid or Cloud Resource Provider's Image ID 

Can any one please look in to

Additional info:
 rpm -qa | grep aeolus 
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-all-0.13.16-1.el6cf.noarch
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
Comment 2 Rehana 2012-10-04 07:05:22 EDT
Created attachment 621564 [details]
ID
Comment 3 Rehana 2012-10-04 07:06:05 EDT
Created attachment 621565 [details]
import_UUID
Comment 4 Rehana 2012-10-04 07:06:37 EDT
Created attachment 621566 [details]
afr_imp
Comment 5 Rehana 2012-10-04 07:08:20 EDT
Created attachment 621567 [details]
img_detail
Comment 6 Tzu-Mainn Chen 2012-10-04 13:06:39 EDT
Looks like the real issue is the mis-labeled Cloud Provider's Image ID field in the image details page.  Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-October/012846.html
Comment 7 Matt Wagner 2012-10-05 10:22:56 EDT
In case I wasn't the only one baffled by this, here is what I've figured out after talking to Mainn:

1.) On the image import page, using something like "ami-b5e955dc" (as in the screenshot) is correct. That is what we call the "Cloud Resource Provider's Image ID." It's what the remote cloud provider uses to identify images.

2.) The bug here is not on the image import page. It is on the image *detail* page, where we showed the provider's image ID (in #1) under the label "Image UUID", which was plain wrong. We also had "Cloud Resource Provider's Image ID" displaying some sort of UUID, which was also plain wrong.

3.) Mainn's patch fixes #2. There is no change to the image import page, which is correct. (#813218 fixed that.)
Comment 8 Matt Wagner 2012-10-05 10:54:15 EDT
On master and 1.1:

commit 51746eea23e4346c42c4aa85f70f19a1bf1cf30b
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Thu Oct 4 13:04:46 2012 -0400

    BZ863055 - correct provider's image ID field
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 67980a6375a7674322bbb00d75f1a0eb39867a5e)
Comment 10 Shveta 2012-10-10 20:11:28 EDT
Fixed.
Cloud Resource Provider's Image ID  shows the image id and UUID is removed.


rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 11 Shveta 2012-10-10 20:13:37 EDT
Created attachment 625247 [details]
image id
Comment 13 errata-xmlrpc 2012-12-04 10:23:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.