Bug 863111 - more or less completely nonfunctional
more or less completely nonfunctional
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 09:07 EDT by Bill Nottingham
Modified: 2014-03-16 23:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 04:18:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-10-04 09:07:58 EDT
Description of problem:

1) It starts, connects, but on the first attempt to actually use the connection:

Oct  4 09:01:26 nostromo nm-openvpn[2346]: SIGTERM[hard,] received, process exiting

2) Once this happens, it refuses to even try to reconnect until reboot:

Oct  4 09:01:32 nostromo NetworkManager[1373]: <info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 2550
Oct  4 09:01:32 nostromo NetworkManager[1373]: <info> VPN service 'openvpn' appeared; activating connections
Oct  4 09:01:32 nostromo NetworkManager[1373]: <error> [1349355692.844582] [nm-vpn-connection.c:1405] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

Bouncing either NM or the shell just makes it worse - bouncing the shell drops the VPN bits of the menu entirely; bouncing NM shows multiple copies of each device in the menu (still without bringing the VPN menu back.)

Version-Release number of selected component (if applicable):

NetworkManager-0.9.7.0-1.git20120820.fc18.x86_64
NetworkManager-openvpn-0.9.3.997-3.fc18.x86_64
gnome-shell-3.6.0-1.fc18.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Attempt to use it
  
Actual results:

Wailing, gnashing of teeth, lamentations, misery due to inability to connect.

Expected results:

Wailing, gnashing of teeth, lamentations, misery due to e-mail received over working VPN.
Comment 1 Bill Nottingham 2012-10-04 09:37:42 EDT
I tried with NetworkManager-openvpn-0.9.6.0-1.fc18.x86_64; it lasted ~15 minutes before dying with SIGTERM instead of falling over immediately. Other than that, it's the same (refuses to reconnect with secrets failure, etc.)
Comment 2 Orion Poplawski 2012-12-20 12:12:48 EST
Is this a dup of bug #848217?
Comment 3 Bill Nottingham 2012-12-20 14:01:48 EST
Connecting to it works these days. I haven't tried creating new ones.
Comment 4 Jirka Klimes 2013-01-08 08:43:21 EST
Bill, do you still see some issues?
Comment 5 Bill Nottingham 2013-01-08 17:12:05 EST
No, it works now for me.
Comment 6 Jirka Klimes 2013-01-09 04:18:44 EST
OK, I'm closing this then.
However, I should note there is a problem in gnome-shell's secret agent not re-registering itself with NM when NM is restarted, which causes that VPN doesn't work - bug 888068.

Note You need to log in before you can comment on or make changes to this bug.