Bug 863182 - SystemError: (32, 'umount: /mnt/sysimage: target is busy.\n (In some cases useful info about processes that use\n the device is found by lsof(8) or fuser(1))')
SystemError: (32, 'umount: /mnt/sysimage: target is busy.\n (In some c...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:60423c9451d5c3c500af9b937e8...
:
: 864713 884599 (view as bug list)
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2012-10-04 11:47 EDT by Chuck Forsberg
Modified: 2013-12-19 13:55 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 13:55:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (651 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: release (24 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: anaconda.log (2.94 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: type (9 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: environ (761 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: storage.log (186.10 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: version (11 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: program.log (75.35 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: product (6 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: syslog (122.57 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: install.log (104.17 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: packaging.log (2.77 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details
File: anaconda-tb (536.11 KB, text/plain)
2012-10-04 11:47 EDT, Chuck Forsberg
no flags Details

  None (edit)
Description Chuck Forsberg 2012-10-04 11:47:16 EDT
Version-Release number of selected component:
anaconda-18.11

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/isys/__init__.py", line 151, in umount
:    rc = _isys.umount(what)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 652, in unmount
:    rc = isys.umount(self._mountpoint, removeDir = False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 859, in teardown
:    return self.unmount(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 740, in _preTeardown
:    self.format.teardown()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 752, in teardown
:    if not self._preTeardown(recursive=recursive):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3032, in findExistingInstallations
:    device.teardown()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 477, in reset
:    self.roots = findExistingInstallations(self.devicetree)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 104, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:SystemError: (32, 'umount: /mnt/sysimage: target is busy.\n        (In some cases useful info about processes that use\n         the device is found by lsof(8) or fuser(1))')
Comment 1 Chuck Forsberg 2012-10-04 11:47:20 EDT
Created attachment 621717 [details]
File: ifcfg.log
Comment 2 Chuck Forsberg 2012-10-04 11:47:21 EDT
Created attachment 621718 [details]
File: release
Comment 3 Chuck Forsberg 2012-10-04 11:47:23 EDT
Created attachment 621719 [details]
File: anaconda.log
Comment 4 Chuck Forsberg 2012-10-04 11:47:24 EDT
Created attachment 621720 [details]
File: type
Comment 5 Chuck Forsberg 2012-10-04 11:47:26 EDT
Created attachment 621721 [details]
File: environ
Comment 6 Chuck Forsberg 2012-10-04 11:47:27 EDT
Created attachment 621722 [details]
File: storage.log
Comment 7 Chuck Forsberg 2012-10-04 11:47:29 EDT
Created attachment 621723 [details]
File: version
Comment 8 Chuck Forsberg 2012-10-04 11:47:31 EDT
Created attachment 621724 [details]
File: program.log
Comment 9 Chuck Forsberg 2012-10-04 11:47:33 EDT
Created attachment 621725 [details]
File: product
Comment 10 Chuck Forsberg 2012-10-04 11:47:34 EDT
Created attachment 621726 [details]
File: syslog
Comment 11 Chuck Forsberg 2012-10-04 11:47:36 EDT
Created attachment 621727 [details]
File: install.log
Comment 12 Chuck Forsberg 2012-10-04 11:47:38 EDT
Created attachment 621728 [details]
File: hashmarkername
Comment 13 Chuck Forsberg 2012-10-04 11:47:40 EDT
Created attachment 621729 [details]
File: packaging.log
Comment 14 Chuck Forsberg 2012-10-04 11:47:41 EDT
Created attachment 621730 [details]
File: cmdline_file
Comment 15 Chuck Forsberg 2012-10-04 11:47:43 EDT
Created attachment 621731 [details]
File: anaconda-tb
Comment 16 Chris Lumens 2012-10-10 08:49:07 EDT
*** Bug 864713 has been marked as a duplicate of this bug. ***
Comment 17 drBabus 2012-11-29 14:25:30 EST
Happened when I changed the installationlanguage to english (UK), nothing else had been done prior to this.

Package: anaconda-18.29.2-1.fc18.x86_64
OS Release: Fedora release 18
Comment 18 Flóki Pálsson 2013-01-08 17:19:45 EST
chosing keyboard.

Package: anaconda-18.37.11
OS Release: Fedora release 18
Comment 19 Christopher Rose 2013-01-15 13:08:10 EST
Trying to upgrade to Fedora 18 from 17

Package: anaconda-18.37.11
OS Release: Fedora release 18
Comment 20 Brian Lane 2013-01-15 13:12:19 EST
Please switch to tty2 (ctrl-alt-f2) and attach the logs from /tmp/*log to this bug as individual text/plain files.

Also please try and describe what you were doing in as much detail as possible.
Comment 21 John Reiser 2013-02-26 12:59:33 EST
boot DVD for install to i686. <Return> to select default language.  Get to hub screen, click on Storage.  Error dialog appears.

Package: anaconda-18.37.11
Architecture: i686
OS Release: Fedora release 18
Comment 22 Brian Lane 2013-08-07 19:50:34 EDT
*** Bug 884599 has been marked as a duplicate of this bug. ***
Comment 23 Brian Lane 2013-12-19 13:55:38 EST
I haven't been able to reproduce this and there isn't enough info to figure out exactly what's holding /mnt/sysimage open.

Note You need to log in before you can comment on or make changes to this bug.