Bug 863236 - evolution couldn't close
evolution couldn't close
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 14:53 EDT by Mikhail
Modified: 2014-02-05 07:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:27:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evolution backtrace (18.12 KB, text/plain)
2012-10-04 14:53 EDT, Mikhail
no flags Details
Evolution backtrace 2 (18.12 KB, text/plain)
2012-10-04 14:57 EDT, Mikhail
no flags Details
Evolution screenshot (128.83 KB, image/png)
2012-10-04 15:03 EDT, Mikhail
no flags Details
Evolution backtrace 3 (19.79 KB, text/plain)
2012-10-06 05:24 EDT, Mikhail
no flags Details
Evolution screenshot (91.98 KB, image/png)
2012-10-06 05:27 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-10-04 14:53:34 EDT
Created attachment 621804 [details]
Evolution backtrace

Description of problem:
evolution couldn't close
Comment 1 Mikhail 2012-10-04 14:57:37 EDT
Created attachment 621806 [details]
Evolution backtrace 2
Comment 2 Mikhail 2012-10-04 14:58:31 EDT
$ rpm -qa | grep evolution | sort
evolution-3.5.92-2.fc18.i686
evolution-data-server-3.5.92-1.fc18.i686
evolution-data-server-debuginfo-3.5.92-1.fc18.i686
evolution-debuginfo-3.5.92-2.fc18.i686
evolution-ews-3.5.92-1.fc18.i686
evolution-ews-debuginfo-3.5.92-1.fc18.i686
Comment 3 Mikhail 2012-10-04 15:03:55 EDT
Created attachment 621808 [details]
Evolution screenshot
Comment 4 Mikhail 2012-10-06 05:24:53 EDT
Created attachment 622655 [details]
Evolution backtrace 3
Comment 5 Mikhail 2012-10-06 05:27:15 EDT
Created attachment 622656 [details]
Evolution screenshot
Comment 6 Milan Crha 2012-10-15 11:32:14 EDT
Thanks for a bug report. I see in the backtraces that one thread is searching for a contact photo of the message you selected, waiting for a response from the evolution-addressbook-factory, which blocks the other threads, also trying to search for contact's photo. It's OK to block other threads, but it's not OK to wait for the addressbook factory response that long. The evolution won't quit, because it requires all contact photo requests being finished.

Could you get a backtrace of running evolution-addressbook-factory, please? There should be shown what it is waiting for/trying to do. Thanks in advance.
Comment 7 Mike Chambers 2012-12-03 11:08:31 EST
I also see long waits (over 2 minutes for my current opened app to close and still waiting) for evolution to close, or not at all, whether there was an error or not.  Now, after reading above, I went back into my preferences and unchecked "show photograph" of emails from users.  Went to close it and still waiting.  Going to kill it and then reopen and see if has any issues with that preference unchecked (for now).  And after reopening evolution again, and then closing, it waited a bit (didn't time it, but was def under a minute) but it did close this time.

BTW, all I do with evolution or was doing this time around, was just clicking on emails and previewing emails, not even opening nor replying to any at the moment.

AND it's on KDE (I don't use gnome itself).

[mike@scrappy ~]$ rpm -qa |grep evolution
evolution-3.6.2-3.fc18.x86_64
evolution-bogofilter-3.6.2-3.fc18.x86_64
evolution-data-server-3.6.2-2.fc18.x86_64
Comment 8 Mike Chambers 2012-12-03 11:10:44 EST
Also, is this related to..

https://bugzilla.redhat.com/show_bug.cgi?id=880825
Comment 9 Milan Crha 2012-12-04 06:21:05 EST
(In reply to comment #8)
> Also, is this related to..
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=880825

Maybe, I'm still not sure. It seems to me that the common part is the status bar, being full of pending actions. The backtrace from comment #4 shows the main thread repainting a window. If I recall correctly, the CPU usage is also higher than usually. That all can be related or not, though the redraws and higher CPU usage is probably caused by the spinner redraw. I have a test application, which emulates it too, though it doesn't have influence on parts I would expect, like delivery of an idle callback.
Comment 10 Mike Chambers 2012-12-05 10:28:54 EST
Still takes a bit to close but so far does indeed close though.  And no bugs like I was getting when had the photograph options turned on, whereas with that option off, no crashes as of yet.
Comment 11 Maël Lavault 2013-02-19 15:17:34 EST
I have the same problem, most of the time  evolution bar is full of pending action and won't close, that's painfully anoying when you use it everyday to have to kill the process to quit. And it make my notebook heat a lot ...
Comment 12 Milan Crha 2013-02-20 02:27:45 EST
There were done changes for 3.6.4 which should (fully or partially) address this issue. The date for a release is not set yet, but I guess it'll be done within a week or two.
Comment 13 Maël Lavault 2013-04-16 14:41:50 EDT
I still got the problem, I am still not able to close my evolution, all widgets in the window are desactivated but the window stay. It has been month now that this problem exist...

It is VERY frustrating.
Comment 14 Milan Crha 2013-04-17 02:10:49 EDT
Maël, did you update to 3.6.4 of (all) evolution package(s)?
Comment 15 Maël Lavault 2013-04-19 12:35:13 EDT
Yes I have a fedora 18 setup fully updated, Evolution is version 3.6.4
Comment 16 Milan Crha 2013-04-22 05:33:36 EDT
OK, thanks. I thought it's like updating only evolution, but not evolution-data-server, but as you have the machine fully updated, then that's OK. One possible thing would be bug #953641. Could you try to downgrade gcr and do the other steps as described in that bug report?
Comment 17 Fedora End Of Life 2013-12-21 04:02:33 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Fedora End Of Life 2014-02-05 07:27:16 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.