Bug 863321 - API:adding new vsphere provider need more checks to match the data as mentioned in json file
API:adding new vsphere provider need more checks to match the data as mention...
Status: CLOSED DUPLICATE of bug 865833
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Mike Orazi
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 02:09 EDT by pushpesh sharma
Modified: 2014-08-04 18:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 11:02:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 pushpesh sharma 2012-10-05 02:10:00 EDT
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.16-1.el6cf.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
Comment 3 pushpesh sharma 2012-10-05 08:43:21 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

[root@dhcp201-113 ~]# cat //etc/imagefactory/vsphere.json 
{
  "vsphere-default":
  {
    "api-url":   "https://10.x.x.x/sdk",
    "datastore":    "datastore1",
    "network_name": "VM Network"
  }
}


[root@dhcp201-113 ~]#  curl -X POST -d '<provider><name>vsphere-xxx</name><url>http://localhost:3002/api</url><provider_type id="4"/><deltacloud_provider>10.x.x.x</deltacloud_provider></provider>' -H "Content-Type: application/xml" -H "Accept: application/xml" --insecure -u admin:password https://10.x.x.x:443/conductor/api/providers
<provider href='https://10.x.x.x/conductor/api/providers/131' id='131'>
<name>vsphere-xxx</name>
<url>http://localhost:3002/api</url>
<provider_type>vsphere</provider_type>
<deltacloud_provider>10.x.x.x</deltacloud_provider>
</provider>


Expected results:

It should accept only 'vsphere-default' as the name of a provider.
Comment 4 Mike Orazi 2012-10-10 10:37:39 EDT
The underlying issue is that a file in etc does not exist.  The API will not create that nor restart imagefactory for 1.1.  A future release of imagefactory will make this interation parameter based and remove the need for the file in etc.
Comment 5 Dave Johnson 2012-10-12 11:02:38 EDT
This failure is related to bug 847798 which covered preventing the user from updating rhevm provider names unless they match a value within the rhevm.json file and was cloned to bug 865833 to cover the vsphere side.  Marking this as a duplicate of 865833.

*** This bug has been marked as a duplicate of bug 865833 ***

Note You need to log in before you can comment on or make changes to this bug.