Bug 865833 - prevent editting vsphere provider name
prevent editting vsphere provider name
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity medium
: beta6
: ---
Assigned To: Jozef Zigmund
Dave Johnson
: Triaged
: 863321 866483 (view as bug list)
Depends On: 804926 847798
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 10:57 EDT by Dave Johnson
Modified: 2012-12-04 10:08 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Attempts to "push all" after changing a provider name returned an error: "Failed. Response code = 500. Response message = Internal Server Error" This bug fix ensures the provider name cannot be edited.
Story Points: ---
Clone Of: 847798
Environment:
Last Closed: 2012-12-04 10:08:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vsphere_provider name (72.52 KB, image/png)
2012-10-24 15:13 EDT, Shveta
no flags Details

  None (edit)
Comment 1 Dave Johnson 2012-10-12 11:02:38 EDT
*** Bug 863321 has been marked as a duplicate of this bug. ***
Comment 2 Dave Johnson 2012-10-16 15:31:19 EDT
*** Bug 866483 has been marked as a duplicate of this bug. ***
Comment 3 James Laska 2012-10-16 15:58:45 EDT
With no verification that the provider name in .json matches the web-ui provider name, it's fairly easy for an administrator to shoot themselves in the foot.  While the failure scenario is resolvable, I believe the ease in reproducing this issue warrants review as a 1.1 release blocker.

Adding blocker? and qa_ack+
Comment 5 Jozef Zigmund 2012-10-18 11:45:05 EDT
Bugfix was sent to the mailing list: https://lists.fedorahosted.org/pipermail/aeolus-devel/2012-October/012972.html
Comment 6 Tzu-Mainn Chen 2012-10-22 11:28:18 EDT
ACk'd and pushed to master/1.1:

Author: Jozef Zigmund <jzigmund at redhat.com>
Date:   Mon Oct 22 10:49:56 2012 -0400

    Used the same way as for rhevm provider name
    
    https://bugzilla.redhat.com/show_bug.cgi?id=865833
    
    Signed-off-by: Tzu-Mainn Chen <tzumainn@redhat.com>
    (cherry picked from commit 886b2a6b5f5fce9b3b3abc3a831ada4c10c65917)
Comment 8 Shveta 2012-10-24 15:13:55 EDT
Created attachment 632950 [details]
vsphere_provider name
Comment 9 Shveta 2012-10-24 15:15:20 EDT
Vsphere provider cannot be edited to any value.
It accepts only values matching to json file.

Tested in Puddle 6 :
rpm -qa|grep aeolus
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-0.13.21-1.el6cf.noarch
rubygem-aeolus-cli-0.7.6-1.el6cf.noarch
aeolus-conductor-doc-0.13.21-1.el6cf.noarch
aeolus-all-0.13.21-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.21-1.el6cf.noarch
Comment 11 errata-xmlrpc 2012-12-04 10:08:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.