This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863337 - no icons in menu
no icons in menu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 872691 879061 (view as bug list)
Depends On:
Blocks: F18Xfce
  Show dependency treegraph
 
Reported: 2012-10-05 03:18 EDT by Marcus Moeller
Modified: 2013-02-09 06:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-09 06:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2012-10-05 03:18:38 EDT
Description of problem:

In the latest version of Xfce include in Fedora 18, the menu does no longer display icons. This could of course be reset in Appearance / Settings / Show images in menu, but it would be a good option to default to it. Past versions always displayed icons in menus, as it makes it much easier to find elements.
Comment 1 Kevin Fenzi 2012-10-05 13:22:24 EDT
This is the default behavior in 4.10... I think it was done to allow for faster menu drawing. 

If you would like us to change this default, please discuss on the xfce list: 
http://lists.fedoraproject.org/mailman/listinfo/xfce
Comment 2 Marcus Moeller 2012-10-05 13:23:24 EDT
I already raised the topic on the list.
Comment 3 Christoph Wickert 2012-10-06 18:29:05 EDT
I think we should use buttons by default, because the panel menu plugin has "Show icons" enabled but still no menus are shown unless enabled in xfce4-appearance-settings. This is confusing.

I'll prepare a patch.
Comment 4 Christoph Wickert 2012-10-17 18:33:26 EDT
There is something fishy here. We should definitely have buttons by default as /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml contains
    <property name="MenuImages" type="bool" value="true"/>
    <property name="ButtonImages" type="bool" value="true"/>

See http://git.xfce.org/xfce/xfce4-settings/tree/xfsettingsd/xsettings.xml?id=xfce4-settings-4.10.0

I wonder if this is somehow related to bug 867638 where the cursor has theme selected. Somehow xfsettingsd fails to apply the settings.
Comment 5 Christoph Wickert 2012-10-17 18:47:48 EDT
This is definitely related to the other bug, xfsettingsd doesn't set the xsettings properties, see bug 867638 comment 1.
Comment 6 Marcus Moeller 2012-10-29 05:00:13 EDT
Manually activating the options works, of course.
Comment 7 Christoph Wickert 2012-10-29 07:35:47 EDT
Sure, but that doesn't fix the bug and we already know that because it's the same for the mouse cursor and the window decorations. As soon as you launch one od the settings caplets, the settings channel is created. The real question is: Why does xfsettingsd not create the channels on start?
Comment 8 Raphael Groner 2012-11-03 10:41:50 EDT
The checkbox for "Show icons" in the plugin's dialog should be disabled, grayed or at least with a nice tooltip saying that appearance settings are globally applied. I hope that should be more user friendly.
Maybe this should go to upstream as a feature request.
I don't see much sense in having icons in the desktop menu, but not in the plugin. So upstream should think about removing the specific checkbox from the plugin's dialog. 
(Xfce bugzilla is currently down, otherwise I would have reported myself.)
Comment 9 Christoph Wickert 2012-11-03 11:51:15 EDT
*** Bug 872691 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2012-11-03 11:58:15 EDT
(In reply to comment #8)
> The checkbox for "Show icons" in the plugin's dialog should be disabled,
> grayed or at least with a nice tooltip saying that appearance settings are
> globally applied. I hope that should be more user friendly.
> Maybe this should go to upstream as a feature request.

Yes, please discuss this with the developers and not with us. This bug report is about the bug in xfsettingsd and not about a feature request.

> (Xfce bugzilla is currently down, otherwise I would have reported myself.)

Have you been able to do this in the meantime? If so, please cc cwickert at fpo to the upstream bug.
Comment 11 Raphael Groner 2012-11-04 11:20:11 EST
(In reply to comment #8)
I've found an upstream bug report with a patch suggestion that tries to give more power to the checkbox in the plugin. Not sure if that can be the general solution.

See https://bugzilla.xfce.org/show_bug.cgi?id=9365
Comment 12 Christoph Wickert 2012-11-22 15:34:31 EST
*** Bug 879061 has been marked as a duplicate of this bug. ***
Comment 13 Marek Marczykowski 2013-01-25 10:43:16 EST
The problem for me looks like an error in /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml, which causes xfconfd ignore the whole file.
The erroneous lines:
  <property name="Net" type="empty">
    <property name="ThemeName" type="Adwaita"/>
    <property name="IconThemeName" type="Fedora"/>
There should be of course:
  <property name="Net" type="empty">
    <property name="ThemeName" type="string" value="Adwaita"/>
    <property name="IconThemeName" type="string" value="Fedora"/>

xfconfd complains about this at startup.
Comment 14 Christoph Wickert 2013-01-25 16:44:32 EST
Thanks, I must have been blind to not see this.
Comment 15 Christoph Wickert 2013-01-25 17:08:15 EST
Ok, i fixed this in git and built an update for F18, however rawhide currently has broken deps. I first need to build the rawhide package before I can push this to F18.
Comment 16 Fedora Update System 2013-01-26 09:33:12 EST
xfce4-settings-4.10.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-settings-4.10.0-4.fc18
Comment 17 Fedora Update System 2013-01-28 10:10:07 EST
Package xfce4-settings-4.10.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-settings-4.10.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1563/xfce4-settings-4.10.0-4.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-02-09 06:25:21 EST
xfce4-settings-4.10.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.