This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 867638 - No mouse cursor after login
No mouse cursor after login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-settings (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Xfce
  Show dependency treegraph
 
Reported: 2012-10-17 18:19 EDT by Christoph Wickert
Modified: 2016-12-01 14:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-09 06:25:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2012-10-17 18:19:25 EDT
Description of problem:
The F18 Xfce spin shows no mouse cursor, until one opens xfce4-mouse-settings. Not easy without a cursor, therefor I suggest we treat this as a blocker.

Version-Release number of selected component (if applicable):
xfce4-settings-4.10.0-2.fc18.i686
xfconf-4.10.0-3.fc18.i686

How reproducible:
always

Steps to Reproduce:
1. Boot Xfce spin, e.g, F18 beta TC 4

Actual results:
No mouse cursor, neither in lightdm nor after logging in to Xfce.

Expected results:
There should be a cursor right from the start.

Additional info:
# grep CursorThemeName /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml 
    <property name="CursorThemeName" type="string" value=""/>

It seems Xfce doesn't set a cursor theme. I'll patch it to "default", because /usr/share/icons/default/index.theme always inherits Fedora's standard theme. Currently this is Adwaita. If this doesn't work, I'll patch it to Adwaita directly.
Comment 1 Christoph Wickert 2012-10-17 18:46:46 EDT
Ok, patching to 'default' works, but obviously there is more wrong here:

$ xfconf-query -c xsettings -l
/Gtk/IMModule

Same thing on F17, even same version of xfce4-settings and xfconf:
$ xfconf-query -c xsettings -l
/Gtk/ButtonImages
/Gtk/CanChangeAccels
/Gtk/ColorPalette
/Gtk/CursorThemeName
/Gtk/CursorThemeSize
/Gtk/FontName
/Gtk/IconSizes
/Gtk/IMModule
/Gtk/IMPreeditStyle
/Gtk/IMStatusStyle
/Gtk/KeyThemeName
/Gtk/MenuBarAccel
/Gtk/MenuImages
/Gtk/ToolbarIconSize
/Gtk/ToolbarStyle
/Net/CursorBlink
/Net/CursorBlinkTime
/Net/DndDragThreshold
/Net/DoubleClickDistance
/Net/DoubleClickTime
/Net/EnableEventSounds
/Net/EnableInputFeedbackSounds
/Net/IconThemeName
/Net/SoundThemeName
/Net/ThemeName
/Xft/Hinting
/Xft/RGBA

So obviously all these properties are never set - no surprise that themes for cursor, icons and gtk are not set (they are not set when one opens the settings for the first time).

BTW: I get a cursor when I boot into runlevel 3 and then start Xfce with startx. I wonder if lightdm is doing something wrong here. Both /etc/gtk-2.0/gtkrc and /etc/gtk-3.0/settings.ini set gtk-cursor-theme-name = "Adwaita" and something obviously screws it up before xfsettingsd is started.
Comment 2 Sergio 2012-12-07 13:06:57 EST
Do you still experience this, Cristoph? Or did you patch something?

I'm running the Beta live-CD and the cursor is displayed properly in lightdm and thus in Xfce too.
And yes, AFAICT Xfce doesn't come with anything set-up (at least appearance-wise) so it uses the system's defaults until we change any settings.
Comment 3 Christoph Wickert 2012-12-10 09:19:54 EST
I still have this problem with the F18 beta in KVM. When I boot, xfconf-query only lists the Gtk/IMModule channel.
Comment 4 Kevin Fenzi 2012-12-10 15:56:07 EST
Do you still see this with the Final TC1 compose? 

I'll try and test here... my f18 laptop works just fine, but will test a live image.
Comment 5 Cris D 2012-12-24 08:12:33 EST
F18 Final TC3 - 

I tested this today. I can get certain cursors to change (window resize, scrolls, etc) permanently , but the main pointer fluxuates between the default and custom cursor.  Initial the main cursor was the default one, but change after a few minutes of use.  It then changed back when I switched into a new window.

[cris@localhost ~]$ xfconf-query -c xsettings -l
/Gtk/ButtonImages
/Gtk/CursorThemeName
/Gtk/CursorThemeSize
/Gtk/FontName
/Gtk/IMModule
/Gtk/MenuImages
/Gtk/ToolbarStyle
/Net/EnableEventSounds
/Net/EnableInputFeedbackSounds
/Net/IconThemeName
/Net/ThemeName
/Xft/HintStyle
/Xft/RGBA
[cris@localhost ~]$ xfconf-query -c xsettings -l -p /Gtk/CursorThemeName -v
/Gtk/CursorThemeName  Pulse-Glass
[cris@localhost ~]$
Comment 6 Fedora Update System 2013-01-26 09:33:20 EST
xfce4-settings-4.10.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-settings-4.10.0-4.fc18
Comment 7 Fedora Update System 2013-01-28 10:10:17 EST
Package xfce4-settings-4.10.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-settings-4.10.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1563/xfce4-settings-4.10.0-4.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-09 06:25:31 EST
xfce4-settings-4.10.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Matt Gara 2016-12-01 14:40:40 EST
This bug is back in Fedora 25 xfce spin. I haven't tried to re-enable the mouse pointer through the methods discussed here, I'm downgrading to Fedora 24 because this is a blocker.

Note You need to log in before you can comment on or make changes to this bug.