Bug 863354 - ValueError: Cannot remove extended partition sda4. Logical partitions present.
ValueError: Cannot remove extended partition sda4. Logical partitions present.
Status: CLOSED DUPLICATE of bug 862971
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:cc5d1cdf15e00ff0fef0df30716...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 04:14 EDT by Jens Petersen
Modified: 2012-10-05 04:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 04:20:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (2.98 MB, text/plain)
2012-10-05 04:14 EDT, Jens Petersen
no flags Details
File: environ (882 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: type (9 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: storage.log (1.68 MB, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: version (2 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: program.log (817.92 KB, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: product (6 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: anaconda.log (65.36 KB, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: cmdline_file (163 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: release (33 bytes, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details
File: messages (401.60 KB, text/plain)
2012-10-05 04:15 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2012-10-05 04:14:47 EDT
Description of problem:
after custom partitioning

Version-Release number of selected component:
anaconda-18.12-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.12 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 385, in _removeDevice
:    "Logical partitions present." % dev.name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 425, in registerAction
:    self._removeDevice(action.device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1219, in destroyDevice
:    self.devicetree.registerAction(action)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 684, in updateExtendedPartitions
:    storage.destroyDevice(part)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 782, in doPartitioning
:    updateExtendedPartitions(storage, disks)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 353, in apply
:    doPartitioning(self.storage)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
:    action.apply()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 323, in _on_spoke_clicked
:    self._runSpoke(spoke)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 338, in _on_spoke_clicked
:    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
:ValueError: Cannot remove extended partition sda4.  Logical partitions present.
Comment 1 Jens Petersen 2012-10-05 04:14:58 EDT
Created attachment 622034 [details]
File: anaconda-tb
Comment 2 Jens Petersen 2012-10-05 04:15:01 EDT
Created attachment 622035 [details]
File: environ
Comment 3 Jens Petersen 2012-10-05 04:15:03 EDT
Created attachment 622036 [details]
File: type
Comment 4 Jens Petersen 2012-10-05 04:15:05 EDT
Created attachment 622037 [details]
File: ifcfg.log
Comment 5 Jens Petersen 2012-10-05 04:15:12 EDT
Created attachment 622038 [details]
File: storage.log
Comment 6 Jens Petersen 2012-10-05 04:15:14 EDT
Created attachment 622039 [details]
File: version
Comment 7 Jens Petersen 2012-10-05 04:15:18 EDT
Created attachment 622040 [details]
File: program.log
Comment 8 Jens Petersen 2012-10-05 04:15:20 EDT
Created attachment 622041 [details]
File: product
Comment 9 Jens Petersen 2012-10-05 04:15:22 EDT
Created attachment 622042 [details]
File: anaconda.log
Comment 10 Jens Petersen 2012-10-05 04:15:24 EDT
Created attachment 622043 [details]
File: hashmarkername
Comment 11 Jens Petersen 2012-10-05 04:15:26 EDT
Created attachment 622044 [details]
File: cmdline_file
Comment 12 Jens Petersen 2012-10-05 04:15:28 EDT
Created attachment 622045 [details]
File: release
Comment 13 Jens Petersen 2012-10-05 04:15:30 EDT
Created attachment 622046 [details]
File: messages
Comment 14 Jens Petersen 2012-10-05 04:20:40 EDT
I guess this is a duplicate of bug 862971.

This one is via custom partition screen
but looks like backtrace is from same place.

*** This bug has been marked as a duplicate of bug 862971 ***

Note You need to log in before you can comment on or make changes to this bug.