Bug 863593 - KeyError: 'payload'
KeyError: 'payload'
Status: CLOSED DUPLICATE of bug 863582
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:521bf61e8c6f3e185c00f3bf36d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 20:25 EDT by Tim Flink
Modified: 2012-10-06 15:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 15:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (195.86 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: product (6 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: type (9 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: storage.log (62.06 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: version (2 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: environ (764 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: anaconda.log (2.43 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: syslog (68.25 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: packaging.log (2.92 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: cmdline_file (87 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: release (24 bytes, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details
File: program.log (32.05 KB, text/plain)
2012-10-05 20:25 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2012-10-05 20:25:11 EDT
Description of problem:
I attempted an install with f18b-smoke5 (anaconda-18.13-1) using a VM with an already existing F18 install.

When I attempted autopart, I was told that there was not enough space on the disk. I went through the reclamation process, tried to delete all of the existing partitions and ended up with this traceback


Version-Release number of selected component:
anaconda-18.13

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.13 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 130, in __init__
:    self.payload = kwargs.pop("payload")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 607, in on_continue_clicked
:    dialog = InstallOptions1Dialog(self.data)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 642, in on_continue_clicked
:    self.on_continue_clicked(button)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 642, in on_continue_clicked
:    self.on_continue_clicked(button)
:KeyError: 'payload'
Comment 1 Tim Flink 2012-10-05 20:25:15 EDT
Created attachment 622507 [details]
File: anaconda-tb
Comment 2 Tim Flink 2012-10-05 20:25:16 EDT
Created attachment 622508 [details]
File: product
Comment 3 Tim Flink 2012-10-05 20:25:18 EDT
Created attachment 622509 [details]
File: type
Comment 4 Tim Flink 2012-10-05 20:25:20 EDT
Created attachment 622510 [details]
File: ifcfg.log
Comment 5 Tim Flink 2012-10-05 20:25:22 EDT
Created attachment 622511 [details]
File: storage.log
Comment 6 Tim Flink 2012-10-05 20:25:24 EDT
Created attachment 622512 [details]
File: version
Comment 7 Tim Flink 2012-10-05 20:25:25 EDT
Created attachment 622513 [details]
File: environ
Comment 8 Tim Flink 2012-10-05 20:25:28 EDT
Created attachment 622514 [details]
File: anaconda.log
Comment 9 Tim Flink 2012-10-05 20:25:30 EDT
Created attachment 622515 [details]
File: syslog
Comment 10 Tim Flink 2012-10-05 20:25:32 EDT
Created attachment 622516 [details]
File: hashmarkername
Comment 11 Tim Flink 2012-10-05 20:25:33 EDT
Created attachment 622517 [details]
File: packaging.log
Comment 12 Tim Flink 2012-10-05 20:25:35 EDT
Created attachment 622518 [details]
File: cmdline_file
Comment 13 Tim Flink 2012-10-05 20:25:37 EDT
Created attachment 622519 [details]
File: release
Comment 14 Tim Flink 2012-10-05 20:25:39 EDT
Created attachment 622520 [details]
File: program.log
Comment 15 Adam Williamson 2012-10-05 20:30:03 EDT
This seems very likely to be related to https://bugzilla.redhat.com/show_bug.cgi?id=863582 .
Comment 16 Chris Lumens 2012-10-06 15:08:03 EDT

*** This bug has been marked as a duplicate of bug 863582 ***

Note You need to log in before you can comment on or make changes to this bug.