This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863582 - KeyError: 'payload'
KeyError: 'payload'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:6545acf7a7b7e7cf651044398db...
:
: 863593 863711 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-05 18:10 EDT by Steve Tyler
Modified: 2012-10-15 20:24 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 20:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-05 18:10 EDT, Steve Tyler
no flags Details
File: anaconda-tb (3.28 MB, text/plain)
2012-10-05 18:10 EDT, Steve Tyler
no flags Details
File: environ (885 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: type (9 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: storage.log (1.97 MB, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: version (2 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: program.log (786.82 KB, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: product (6 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: anaconda.log (40.58 KB, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: release (33 bytes, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details
File: messages (491.85 KB, text/plain)
2012-10-05 18:11 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-10-05 18:10:45 EDT
Version-Release number of selected component:
anaconda-18.13-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.0-0.rc6.git0.2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.13 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 130, in __init__
:    self.payload = kwargs.pop("payload")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 607, in on_continue_clicked
:    dialog = InstallOptions1Dialog(self.data)
:KeyError: 'payload'
Comment 1 Steve Tyler 2012-10-05 18:10:47 EDT
Created attachment 622477 [details]
File: ifcfg.log
Comment 2 Steve Tyler 2012-10-05 18:10:58 EDT
Created attachment 622478 [details]
File: anaconda-tb
Comment 3 Steve Tyler 2012-10-05 18:11:00 EDT
Created attachment 622479 [details]
File: environ
Comment 4 Steve Tyler 2012-10-05 18:11:01 EDT
Created attachment 622480 [details]
File: type
Comment 5 Steve Tyler 2012-10-05 18:11:07 EDT
Created attachment 622481 [details]
File: storage.log
Comment 6 Steve Tyler 2012-10-05 18:11:09 EDT
Created attachment 622482 [details]
File: version
Comment 7 Steve Tyler 2012-10-05 18:11:13 EDT
Created attachment 622483 [details]
File: program.log
Comment 8 Steve Tyler 2012-10-05 18:11:15 EDT
Created attachment 622484 [details]
File: product
Comment 9 Steve Tyler 2012-10-05 18:11:16 EDT
Created attachment 622485 [details]
File: anaconda.log
Comment 10 Steve Tyler 2012-10-05 18:11:18 EDT
Created attachment 622486 [details]
File: hashmarkername
Comment 11 Steve Tyler 2012-10-05 18:11:19 EDT
Created attachment 622487 [details]
File: cmdline_file
Comment 12 Steve Tyler 2012-10-05 18:11:21 EDT
Created attachment 622488 [details]
File: release
Comment 13 Steve Tyler 2012-10-05 18:11:24 EDT
Created attachment 622489 [details]
File: messages
Comment 14 Steve Tyler 2012-10-05 18:30:01 EDT
Reproduced with:
1. Click "Installation Destination".
2. Click "Continue".

With Fedora-18-Nightly-20121003.08-x86_64-Live-desktop.iso in a VM.

The target was an empty VM disk image:
$ qemu-img create f18-test-3.img 10G
$ hexdump -C f18-test-3.img 
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
280000000

$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-18-Nightly-20121003.08-x86_64-Live-desktop.iso -usb -vga qxl -boot menu=on
Comment 15 Adam Williamson 2012-10-05 18:55:33 EDT
Just picking an empty disk as an install target for a live install with anaconda 18.13.

Package: anaconda-18.13-1.fc18.x86_64
OS Release: Fedora release 18
Comment 16 Adam Williamson 2012-10-05 19:04:15 EDT
note that, interestingly, you can simply go to the disk selection spoke, have a disk selected, and click 'Done' at top left, and it'll work - anaconda will go with autopart on that disk, assuming it has enough free space. you don't actually have to click 'Continue'. that seems a little strange from a UI perspective, but it works around this bug.
Comment 17 Adam Williamson 2012-10-05 19:05:56 EDT
even with that workaround, this is obviously a beta blocker, it prevents access to custom partitioning or the 'help me free space' process, so it hits Alpha "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data".
Comment 18 Adam Williamson 2012-10-05 20:28:09 EDT
I believe this bug actually happens _only_ if the target disk is empty (no partitions, I guess is the definition of 'empty' here.) if the target disk is populated, it seems to work OK (though of course you might hit https://bugzilla.redhat.com/show_bug.cgi?id=863348 later).
Comment 19 Tim Flink 2012-10-05 20:35:18 EDT
I attempted to install in a VM with f18b-smoke5 (anaconda-18.13-1) using an empty disk

When I selected the disk and attempted to use autopart, this traceback showed up.


Package: anaconda-18.13
OS Release: Fedora release 18
Comment 20 Tim Flink 2012-10-05 20:37:34 EDT
(In reply to comment #18)
> I believe this bug actually happens _only_ if the target disk is empty (no
> partitions, I guess is the definition of 'empty' here.) if the target disk
> is populated, it seems to work OK (though of course you might hit
> https://bugzilla.redhat.com/show_bug.cgi?id=863348 later).

I tried an install using f18b-smoke5 (anaconda-18.13-1) on a disk that had an old install of F18 on it. I hit https://bugzilla.redhat.com/show_bug.cgi?id=863593 which looks similar to my uneducated eyes but I could well be wrong.
Comment 21 Adam Williamson 2012-10-05 21:05:32 EDT
well you hit it later, which is interesting. I did a test with a populated disk where I could get into the guided 'free up space' workflow and then it crashed when trying to remove partitions - but it crashed with 863348, not 863593. I also did a test with a populated disk and using *custom* partitioning, and that actually worked properly: I could remove the existing partitions and create new ones and complete the install, all successfully.
Comment 22 John Reiser 2012-10-06 11:34:03 EDT
For Installation Destination, choose harddrive with GPT but no partitions.  Click Continue.

Package: anaconda-18.13
OS Release: Fedora release 18
Comment 23 Chris Lumens 2012-10-06 15:08:03 EDT
*** Bug 863593 has been marked as a duplicate of this bug. ***
Comment 24 Chris Lumens 2012-10-06 17:38:10 EDT
This is kinda hastily put together, but you can try:

updates=http://clumens.fedorapeople.org/13updates.img

And then I'll deal with really submitting patches next week.
Comment 25 Chris Lumens 2012-10-06 17:42:36 EDT
*** Bug 863711 has been marked as a duplicate of this bug. ***
Comment 26 Fedora Update System 2012-10-08 20:20:44 EDT
anaconda-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.14-1.fc18
Comment 27 Fedora Update System 2012-10-09 13:20:08 EDT
Package anaconda-18.14-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.14-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15707/anaconda-18.14-1.fc18
then log in and leave karma (feedback).
Comment 28 Adam Williamson 2012-10-10 14:22:15 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Accepted as a blocker per Alpha criterion "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data".
Comment 29 Kamil Páral 2012-10-15 10:20:52 EDT
I can't reproduce the original bug with anaconda 18.12 and therefore I can't verify that it's fixed.

Steve, Tim, Adam, please try to reproduce with Beta TC4, thanks.
Comment 30 Steve Tyler 2012-10-15 10:28:47 EDT
(In reply to comment #29)
> I can't reproduce the original bug with anaconda 18.12 and therefore I can't
> verify that it's fixed.
> 
> Steve, Tim, Adam, please try to reproduce with Beta TC4, thanks.

The reports are against 18.13 ...
Comment 31 Adam Williamson 2012-10-15 20:24:56 EDT
I can still reproduce this with my test image that had 18.13, and I can't reproduce it in TC3 (which had 18.14) or TC4 (18.16), so we can close this (18.14 went stable).

Note You need to log in before you can comment on or make changes to this bug.