Bug 863684 - SELinux is preventing firewalld from 'read' accesses on the directory /var/tmp.
SELinux is preventing firewalld from 'read' accesses on the directory /var/tmp.
Status: CLOSED DUPLICATE of bug 863686
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0faa8c01d219bd792dda7797145...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:42 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-06 11:42 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-06 11:42 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-06 11:42:37 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing firewalld from 'read' accesses on the directory /var/tmp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that firewalld should be allowed read access on the tmp directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:object_r:tmp_t:s0
:Target Objects                /var/tmp [ dir ]
:Source                        firewalld
:Source Path                   firewalld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           filesystem-3.1-2.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-10-06 00:42:08 CDT
:Last Seen                     2012-10-06 10:07:17 CDT
:Local ID                      9c9e67ab-ba0c-48cc-9f9e-77c71a31404e
:
:Raw Audit Messages
:type=AVC msg=audit(1349536037.428:22): avc:  denied  { read } for  pid=435 comm="firewalld" name="tmp" dev="sdb3" ino=655413 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:tmp_t:s0 tclass=dir
:
:
:Hash: firewalld,firewalld_t,tmp_t,dir,read
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t tmp_t:dir read;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t tmp_t:dir read;
:
Comment 1 Adam Joseph Cook 2012-10-06 11:42:39 EDT
Created attachment 622753 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:42:41 EDT
Created attachment 622754 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:10:05 EDT

*** This bug has been marked as a duplicate of bug 863686 ***

Note You need to log in before you can comment on or make changes to this bug.