Bug 863686 - SELinux is preventing firewalld from using the 'sys_nice' capabilities.
SELinux is preventing firewalld from using the 'sys_nice' capabilities.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:522a55dffd978f5c78fb8a7fb48...
:
: 863684 863685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:43 EDT by Adam Joseph Cook
Modified: 2012-12-20 11:09 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-06 11:43 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-06 11:43 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-06 11:43:55 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing firewalld from using the 'sys_nice' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that firewalld should have the sys_nice capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:system_r:firewalld_t:s0
:Target Objects                 [ capability ]
:Source                        firewalld
:Source Path                   firewalld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-06 00:42:08 CDT
:Last Seen                     2012-10-06 10:07:17 CDT
:Local ID                      742ded9e-c2b7-4501-9688-cb28fcdef63d
:
:Raw Audit Messages
:type=AVC msg=audit(1349536037.422:18): avc:  denied  { sys_nice } for  pid=435 comm="firewalld" capability=23  scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:system_r:firewalld_t:s0 tclass=capability
:
:
:Hash: firewalld,firewalld_t,firewalld_t,capability,sys_nice
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t self:capability sys_nice;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t self:capability sys_nice;
:
Comment 1 Adam Joseph Cook 2012-10-06 11:43:57 EDT
Created attachment 622757 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:43:58 EDT
Created attachment 622758 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:02:30 EDT
*** Bug 863685 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:04:52 EDT
commit 9a2e953d51357774b32a7f5271501f1893fe8cd4
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Oct 8 10:03:50 2012 +0200

    Firewalld wants sys_nice/setsched
Comment 5 Miroslav Grepl 2012-10-08 04:10:05 EDT
*** Bug 863684 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-10-11 05:04:09 EDT
selinux-policy-3.11.1-36.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-36.fc18
Comment 7 Fedora Update System 2012-10-11 13:22:45 EDT
Package selinux-policy-3.11.1-36.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-36.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15934/selinux-policy-3.11.1-36.fc18
then log in and leave karma (feedback).
Comment 8 Rob K 2012-10-25 20:24:04 EDT
Went to add printer; printer config tool complained that there was no firewalld. yum installed firewalld, did a systemctl start firewalld, and this avc was generated.

Package: (null)
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Rob K 2012-11-01 16:50:59 EDT
Really needs a F17 release to be honest. With the fun surrounding F18 I'm not keen to upgrade.
Comment 10 Miroslav Grepl 2012-11-02 04:54:23 EDT
Could you open a new bug for F17. Basically this is probably more ABRT issue and we could do some testing with a new bug. Thank you.
Comment 11 Fedora Update System 2012-12-20 11:09:51 EST
selinux-policy-3.11.1-36.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.