Bug 863687 - SELinux is preventing firewalld from 'create' accesses on the udp_socket .
SELinux is preventing firewalld from 'create' accesses on the udp_socket .
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:aad43653d4ec092a08ad57d56e6...
:
: 863688 863750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:44 EDT by Adam Joseph Cook
Modified: 2012-12-20 11:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-06 11:44 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-06 11:44 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-06 11:44:26 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing firewalld from 'create' accesses on the udp_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that firewalld should be allowed create access on the  udp_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:system_r:firewalld_t:s0
:Target Objects                 [ udp_socket ]
:Source                        firewalld
:Source Path                   firewalld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-06 00:42:08 CDT
:Last Seen                     2012-10-06 10:07:17 CDT
:Local ID                      46e11451-014d-4e39-9ef5-77ee3cf61bc9
:
:Raw Audit Messages
:type=AVC msg=audit(1349536037.422:17): avc:  denied  { create } for  pid=435 comm="firewalld" scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:system_r:firewalld_t:s0 tclass=udp_socket
:
:
:Hash: firewalld,firewalld_t,firewalld_t,udp_socket,create
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t self:udp_socket create;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t self:udp_socket create;
:
Comment 1 Adam Joseph Cook 2012-10-06 11:44:48 EDT
Created attachment 622759 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:44:49 EDT
Created attachment 622760 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:00:19 EDT
*** Bug 863688 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:00:49 EDT
*** Bug 863750 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-10-08 04:05:50 EDT
commit a0300a8b8c91bad5482812b3bfd714e28acf657f
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Oct 8 09:59:38 2012 +0200

    Allow firewalld to perform  a DNS name resolution
Comment 6 Fedora Update System 2012-10-11 05:04:17 EDT
selinux-policy-3.11.1-36.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-36.fc18
Comment 7 Fedora Update System 2012-10-11 13:22:53 EDT
Package selinux-policy-3.11.1-36.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-36.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15934/selinux-policy-3.11.1-36.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-20 11:09:55 EST
selinux-policy-3.11.1-36.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.