This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 863750 - SELinux is preventing firewalld from 'create' accesses on the netlink_route_socket .
SELinux is preventing firewalld from 'create' accesses on the netlink_route_s...
Status: CLOSED DUPLICATE of bug 863687
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5a5b2c844bdaac83c1e8b367f8b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 03:28 EDT by Mihai Harpau
Modified: 2012-10-08 04:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 03:28 EDT, Mihai Harpau
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 03:28 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2012-10-07 03:28:37 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing firewalld from 'create' accesses on the netlink_route_socket .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that firewalld should be allowed create access on the  netlink_route_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewalld_t:s0
:Target Context                system_u:system_r:firewalld_t:s0
:Target Objects                 [ netlink_route_socket ]
:Source                        firewalld
:Source Path                   firewalld
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-10-06 08:47:00 EEST
:Last Seen                     2012-10-07 09:05:00 EEST
:Local ID                      349f4a5b-abc4-4bd2-836c-40a2f7c59bd5
:
:Raw Audit Messages
:type=AVC msg=audit(1349589900.472:12): avc:  denied  { create } for  pid=335 comm="firewalld" scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:system_r:firewalld_t:s0 tclass=netlink_route_socket
:
:
:Hash: firewalld,firewalld_t,firewalld_t,netlink_route_socket,create
:
:audit2allow
:
:#============= firewalld_t ==============
:allow firewalld_t self:netlink_route_socket create;
:
:audit2allow -R
:
:#============= firewalld_t ==============
:allow firewalld_t self:netlink_route_socket create;
:
Comment 1 Mihai Harpau 2012-10-07 03:28:40 EDT
Created attachment 622908 [details]
File: type
Comment 2 Mihai Harpau 2012-10-07 03:28:43 EDT
Created attachment 622909 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:00:49 EDT

*** This bug has been marked as a duplicate of bug 863687 ***

Note You need to log in before you can comment on or make changes to this bug.