Bug 863704 - [abrt] yum-3.4.3-29.fc17: os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/17/fedora/gen'
[abrt] yum-3.4.3-29.fc17: os.py:157:makedirs:OSError: [Errno 13] Permission d...
Status: CLOSED DUPLICATE of bug 854974
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:977a7fdfe7f698e4ce601bb337f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 14:51 EDT by error23
Modified: 2014-01-21 18:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 10:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description error23 2012-10-06 14:51:36 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available fire
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.4-5.fc17.i686
time:           Sat 06 Oct 2012 08:44:49 PM CEST
uid:            1000
username:       error23

backtrace:
:os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/17/fedora/gen'
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 89, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 83, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2709, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1015, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 309, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 135, in doSetup
:    self.ayum.plugins.run('postreposetup')
:  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/yum-plugins/langpacks.py", line 72, in postreposetup_hook
:    infile = repo.getGroups()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1735, in getGroups
:    fn = misc.repo_gen_decompress(fn, 'comps.xml')
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1167, in repo_gen_decompress
:    os.makedirs(dest, mode=0755)
:  File "/usr/lib/python2.7/os.py", line 157, in makedirs
:    mkdir(name, mode)
:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/17/fedora/gen'
:
:Local variables in innermost frame:
:tail: 'gen'
:head: '/var/cache/yum/i386/17/fedora'
:name: '/var/cache/yum/i386/17/fedora/gen'
:mode: 493

smolt_data:
:
:
:General
:=================================
:UUID: 7fe88ce0-e954-4786-95b5-0ee7b9fee820
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4390.18
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3-2330M CPU @ 2.20GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2200
:System Memory: 3271
:System Swap: 5078
:Vendor: TOSHIBA
:System: SATELLITE C660 PSC1QE-03P00FFR
:Form factor: Notebook
:Kernel: 3.3.4-5.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:4473:64560) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:7202:4473:64560) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7169:4473:64560) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7184:4473:64560) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4473:64560) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7177:4473:64560) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller
:(32902:7200:4473:64560) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4318:3043:4473:64656) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(4332:33142:4332:33153) pci, rtl8192ce, NETWORK, RTL8188CE 802.11b/g/n WiFi Adapter
:(4332:33078:4473:64560) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(4318:2682:4473:64656) pci, nouveau, VIDEO, N/A
:(32902:7213:4473:64560) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4473:64560) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4473:64656) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4473:64560) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:4473:64656) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 76726461 74866550 74098777 19202048 19115509 19115509
:/dev/mapper/luks-7ce2d0d9-5879-44d9-912b-dc96ab3d267c /home ext4 4096 4096 78093307 76899731 72990637 19546112 19545892 19545892
:
Comment 1 Zdeněk Pavlas 2012-10-09 10:18:01 EDT

*** This bug has been marked as a duplicate of bug 854974 ***

Note You need to log in before you can comment on or make changes to this bug.