Bug 863745 - [abrt]: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[abrt]: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms...
Status: CLOSED DUPLICATE of bug 862180
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:50f1d93f0d3588d2c9a153d087a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 01:05 EDT by efreeti
Modified: 2013-01-21 08:01 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 16:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description efreeti 2012-10-07 01:05:14 EDT
Description of problem:
I left the computer idle, it went to sleep/suspend (default setting). Next day when I woke up the error was shown

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.0-3.fc18.x86_64 root=UUID=cafa5aff-95fc-4166-a059-ae32a8aa8184 ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 rhgb quiet LANG=en.UTF-8
kernel:         3.6.0-3.fc18.x86_64

backtrace:
:WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
:Hardware name: Aspire 5750G
:Modules linked in: fuse rfcomm bnep snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec coretemp btusb bluetooth kvm_intel snd_hwdep arc4 kvm snd_seq snd_seq_device snd_pcm brcmsmac cordic brcmutil snd_page_alloc mac80211 acer_wmi snd_timer uvcvideo cfg80211 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev sparse_keymap microcode snd rfkill media iTCO_wdt iTCO_vendor_support lpc_ich tg3 mei i2c_i801 soundcore bcma mfd_core uinput i915 nouveau crc32c_intel i2c_algo_bit drm_kms_helper ttm sdhci_pci ghash_clmulni_intel sdhci drm mmc_core i2c_core mxm_wmi video wmi
:Pid: 1881, comm: kworker/u:29 Not tainted 3.6.0-3.fc18.x86_64 #1
:Call Trace:
: [<ffffffff8105b83f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105b89a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa03faca9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
: [<ffffffffa03ed6ab>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
: [<ffffffffa039fd1d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
: [<ffffffffa0321f4e>] ? cfg80211_cqm_rssi_notify+0x2e/0x40 [cfg80211]
: [<ffffffffa039da71>] ? ieee80211_cqm_rssi_notify+0x41/0xa0 [mac80211]
: [<ffffffffa03a03cc>] ieee80211_mgd_probe_ap.part.24+0x12c/0x150 [mac80211]
: [<ffffffffa03a056e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
: [<ffffffff81077957>] process_one_work+0x147/0x4a0
: [<ffffffffa03a0540>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
: [<ffffffff8107985e>] worker_thread+0x15e/0x480
: [<ffffffff81079700>] ? manage_workers+0x2f0/0x2f0
: [<ffffffff8107ec23>] kthread+0x93/0xa0
: [<ffffffff81629304>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107eb90>] ? kthread_freezable_should_stop+0x70/0x70
: [<ffffffff81629300>] ? gs_change+0x13/0x13
Comment 1 Giovanni Romero 2012-10-13 21:31:03 EDT
I was adding software (mysql)

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Amit Gautam 2012-10-15 01:28:11 EDT
This issue is happened whenever I enable and disable the wireless.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Ali Kaya 2012-10-17 09:22:49 EDT
I dont know how. It was happened by it self on the back, i see it when i open warning window and i think my wireless device working correct.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Benjamin Kosnik 2012-10-18 12:01:11 EDT
whoa. Wireless crazy messed up here.
Comment 5 luigi.caligiuri 2012-10-23 02:56:06 EDT
The problem ocured at start-up

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Ankur Sinha (FranciscoD) 2012-10-26 20:26:28 EDT
Restarted NetworkManager.service. No crash, but found this in dmesg:

[113147.194290] WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
[113147.194293] Hardware name: Vostro 3400
[113147.194295] Modules linked in: brcmsmac snd_seq_dummy des_generic md4 nls_utf8 cifs dns_resolver fscache bcma usb_storage fuse ebtable_nat ebtables xt_state xt_CHECKSUM nfnetlink_log nfnetlink bridge stp llc lockd sunrpc ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack rfcomm bnep be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec arc4 snd_hwdep snd_seq cordic brcmutil mac80211 cfg80211 snd_seq_device btusb bluetooth rfkill snd_pcm snd_page_alloc snd_timer snd uvcvideo soundcore videobuf2_vmalloc iTCO_wdt iTCO_vendor_support lpc_ich videobuf2_memops mei mfd_core i2c_i801 videobuf2_core videodev media intel_ips r8169 coretemp dell_laptop mii microcode dell_wmi sparse_keymap dcdbas vhost_net tun macvtap macvlan kvm_intel kvm binfmt_misc uinput crc32c_intel ghash_clmulni_intel nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: brcmsmac]
[113147.194430] Pid: 6768, comm: kworker/u:0 Tainted: G        W    3.6.2-4.fc17.x86_64 #1
[113147.194432] Call Trace:
[113147.194442]  [<ffffffff8105b81f>] warn_slowpath_common+0x7f/0xc0
[113147.194447]  [<ffffffff8105b87a>] warn_slowpath_null+0x1a/0x20
[113147.194461]  [<ffffffffa07f4ca9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
[113147.194470]  [<ffffffffa07e76ab>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
[113147.194504]  [<ffffffffa0446d1d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
[113147.194521]  [<ffffffffa03f2f4e>] ? cfg80211_cqm_rssi_notify+0x2e/0x40 [cfg80211]
[113147.194546]  [<ffffffffa0444a71>] ? ieee80211_cqm_rssi_notify+0x41/0xa0 [mac80211]
[113147.194571]  [<ffffffffa04473cc>] ieee80211_mgd_probe_ap.part.24+0x12c/0x150 [mac80211]
[113147.194595]  [<ffffffffa044756e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
[113147.194601]  [<ffffffff81077ae7>] process_one_work+0x147/0x4a0
[113147.194625]  [<ffffffffa0447540>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
[113147.194631]  [<ffffffff8107984e>] worker_thread+0x15e/0x480
[113147.194635]  [<ffffffff810796f0>] ? manage_workers+0x2f0/0x2f0
[113147.194640]  [<ffffffff8107ec13>] kthread+0x93/0xa0
[113147.194646]  [<ffffffff81623884>] kernel_thread_helper+0x4/0x10
[113147.194651]  [<ffffffff8107eb80>] ? kthread_freezable_should_stop+0x70/0x70
[113147.194654]  [<ffffffff81623880>] ? gs_change+0x13/0x13
[113147.194657] ---[ end trace f15b45017ce75f5a ]---
[root@ankur ~]#

Thanks,
Ankur
Comment 7 MG 2012-10-28 07:58:25 EDT
Dear All,

How did it occur?
The problem that I am reporting occurred when yum was downloading a few packages.

Reproducibility.
The problem occurs time-to-time.  I cannot reproduce it deterministically, though.

Comments
1. The wireless connection did not seem to break. 
2. My hardware is: Acer Aspire One D270

Thank you a lot in advance for having a look at this issue.

Regards,
G.


Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Josh Boyer 2012-11-12 16:05:49 EST

*** This bug has been marked as a duplicate of bug 862180 ***
Comment 9 Murilo Augusto 2013-01-21 08:01:06 EST
Eu também tive esse bug,acontece desde depois que instalei o Fedora 18

Note You need to log in before you can comment on or make changes to this bug.