Bug 863969 - Always met conflict and failed to be upgraded to latest devenv instance
Always met conflict and failed to be upgraded to latest devenv instance
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 04:25 EDT by Jianwei Hou
Modified: 2015-05-14 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log (53.98 KB, text/x-log)
2012-10-08 04:25 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2012-10-08 04:25:13 EDT
Created attachment 623334 [details]
upgrade.log

Description of problem:
Try to upgrade instance to latest following https://engineering.redhat.com/trac/Libra/wiki/Test_Migrations_Fork_Ami.
It failed with following error:
Transaction Check Error:
  file /usr/bin/sssh from install of rubygem-openshift-origin-node-0.17.5-1.git.9.6740de3.el6.noarch conflicts with file from package rubygem-stickshift-node-0.17.4-1.el6_3.noarch


Version-Release number of selected component (if applicable):
on devenv-stage_239

How reproducible:
Always


Steps to Reproduce:
1. Launch an old instance(devenv-stage_239)
2. Prepare test data on instance
3. Do server upgrade 
scp ~/li-local from latest devenv ami into instance
scp /etc/yum.repos.d/local.repo from latest devenv image into instance
Change repos to point to candidate on stage_ami (usual step) replace all label 'stage' by 'candidate' in /etc/yum.repos.d/li.repo
yum -y install yum-priorities 
yum update --enablerepo li-local
  
Actual results:
[root@ip-10-191-42-63 misc]# yum -y update --enablerepo li-local
................
Transaction Check Error:
  file /usr/bin/sssh from install of rubygem-openshift-origin-node-0.17.5-1.git.9.6740de3.el6.noarch conflicts with file from package rubygem-stickshift-node-0.17.4-1.el6_3.noarch

Error Summary
-------------


Expected results:
Should upgrade to latest devenv successfully.

Additional info:
Full log is attached.
Comment 1 Jianwei Hou 2012-10-08 04:28:16 EDT
Since I can not upgrade to latest devenv, directories with name "stickshift" is not renamed to "openshift".
migrate-mongo-2.0.18 and hascaledb-migrate-2.0.18.rb failed to run since they require '/var/www/openshift/broker/config/environment' which does not exist, have to replace '/var/www/openshift/broker/config/environment' with '/var/www/stickshift/broker/config/environment' as a work around.
Comment 2 Dan McPherson 2012-10-08 09:28:58 EDT
I have fixed the obsoletes that was causing this issue.  But we haven't written the migration yet for the renames so you will still have issues until that's available
Comment 3 Jianwei Hou 2012-10-22 03:59:34 EDT
Verified on devenv-stage_239

Steps:
1.Launch devenv-stage_239
2.Create test data on it
3.Run the zend_fix_script provided in Bug 864775
4.Modify the li.repo to use the candidate mirror
5.Copy the jbosseap/jbossews related repos and key files from latest devenv
6.Fix the selinux by following the rmillner's comment
7.Run "yum update -y --enablerepo li-local" to upgrade to latest devenv

Upgrade was successful

Note You need to log in before you can comment on or make changes to this bug.