Bug 863994 - '/etc/udev/rules.d/70-persistent-net.rules' is miss on Dell smbios 2.6+ machine
'/etc/udev/rules.d/70-persistent-net.rules' is miss on Dell smbios 2.6+ machine
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 865047
  Show dependency treegraph
 
Reported: 2012-10-08 05:37 EDT by Meng Liang
Modified: 2013-09-11 17:07 EDT (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Dell machines using smbios 2.6 or later use the biosdevname utility for device naming in Red Hat Enterprise Linux 6. Previously when configuring hypervisor networking on machines using biosdevname for device naming the error "cp:cannot stat'/etc/udev/rules.d/70-persistent-net.rules':No such file or directory" was displayed. The hypervisor has been updated and this error is no longer encountered when configuring networking on machines that use biosdevname.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:31:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen-shot of error message (22.27 KB, image/png)
2012-10-12 01:12 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-10-08 05:37:12 EDT
Description of problem:
'/etc/udev/rules.d/70-persistent-net.rules' is miss on Dell smbios 2.6+ machine

Version-Release number of selected component (if applicable):
RHEV Hypervisor 6.3-20121005.0.rhev31.el6_3
RHEV Hypervisor 6.3-20121005.0.el6_3

How reproducible:
Always

Steps to Reproduce:
1. install a clean rheh
2. set network by DHCP (or Static)
  
Actual results:
Error info 'cp:cannot stat'/etc/udev/rules.d/70-persistent-net.rules':No such file or directory' appear during the enable process. See screen shot in attachment file. 
It happens for both DHCP and static setting

Expected results:
Network should be set successfully without error message

Additional info:
Comment 3 Meng Liang 2012-10-08 05:50:46 EDT
The files under /etc/udev/rules.d/ are:
[root@Test-123 admin]# ls /etc/udev/rules.d/
12-vdsm-lvm.rules       71-persistent-node-net.rules  91-drm-modeset.rules
60-raw.rules            80-kvm.rules                  98-kexec.rules
70-persistent-cd.rules  90-hal.rules                  99-fuse.rules
Comment 5 Meng Liang 2012-10-08 06:06:43 EDT
This problem did not happen on RHEV Hypervisor 6.3-20120926.0.el6_3, Thus I set it as a regression.
Comment 9 Meng Liang 2012-10-08 22:26:21 EDT
The bug is fixed on the build hypervisor6-6.3-20121005.0.auto270.el6_3.iso. The network can be set without error message, though there is no file 70-persistent-net.rules in /etc/udev/rules.d/.

Is it the expected result?
Comment 10 Fabian Deutsch 2012-10-09 05:05:42 EDT
Meng,

thanks for testing and to see that it's fixed. And yes - 70-persistent-net.rules is only generated when biosdevname is not beeing used.
Comment 11 Fabian Deutsch 2012-10-09 05:33:28 EDT
http://gerrit.ovirt.org/#/c/8398/
Comment 15 Meng Liang 2012-10-12 01:12:44 EDT
Created attachment 625800 [details]
screen-shot of error message
Comment 17 haiyang,dong 2012-10-29 08:26:25 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Steps to Reproduce:
1. install a clean rheh
2. set network by DHCP 

The network can be set without error message "cp:cannot stat'/etc/udev/rules.d/70-persistent-net.rules':No such file or director",
so this bug has been fixed, change bug status to VERIFIED.
Comment 18 haiyang,dong 2012-12-26 07:13:28 EST
so follow steps of comment 17 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 with Dell smbios 2.6+ machine , bug was fixed on it.
Comment 21 errata-xmlrpc 2013-02-28 11:31:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.