Bug 865047 - '/etc/udev/rules.d/70-persistent-net.rules' is miss on Dell smbios 2.6+ machine
'/etc/udev/rules.d/70-persistent-net.rules' is miss on Dell smbios 2.6+ machine
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression, ZStream
Depends On: 863994
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 13:05 EDT by Chris Pelland
Modified: 2013-09-11 17:07 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-15.el6_3.12
Doc Type: Bug Fix
Doc Text:
Dell machines using smbios 2.6 or later use the biosdevname utility for device naming in Red Hat Enterprise Linux 6. Previously when configuring Hypervisor networking on machines using biosdevname for device naming the error "cp:cannot stat'/etc/udev/rules.d/70-persistent-net.rules':No such file or directory" was displayed. The Hypervisor has been updated and this error is no longer encountered when configuring networking on machines that use biosdevname.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 09:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of An Exception has occurred (24.95 KB, image/png)
2012-10-11 00:23 EDT, haiyang,dong
no flags Details

  None (edit)
Description Chris Pelland 2012-10-10 13:05:49 EDT
This bug has been copied from bug #863994 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 7 Meng Liang 2012-10-10 22:05:19 EDT
Verified this bug on rhevh-hypervisor6-6.3-20121010.2.el6_3
Network can be set successfully without error message.
Comment 8 haiyang,dong 2012-10-11 00:20:16 EDT
Test version:
rhev-hypervisor 6.3-20121010.2.el6_3

At first, clean install rhev-hypervisor 6.3-20121010.2.el6_3,then enter network detail page and configure network by using "DHCP", then press the "apply" button direct.An Exception has occurred during configuring network.(Seen Screenshot.png)
It only happens the "eth*" device, so re-assigned it.
Comment 9 haiyang,dong 2012-10-11 00:23:17 EDT
Created attachment 625320 [details]
screenshot of An Exception has occurred
Comment 10 Ying Cui 2012-10-11 02:29:43 EDT
with comment 8 issue, the network is not configured successful.
Comment 11 Fabian Deutsch 2012-10-11 06:15:48 EDT
I missed somethign while backporting this patch.
Did the exception appear on a machine with or without smbios 2.6+?
Comment 15 haiyang,dong 2012-10-12 05:36:35 EDT
Test version:
rhev-hypervisor6-6.3-20121011.0.el6_3
ovirt-node-2.3.0-15.el6_3.12

1.clean install rhev-hypervisor6-6.3-20121011.0.el6_3,
2.enter network detail page and configure eth0 by using "DHCP", then press the "apply" button directly.

Configure eth0 success, no exception was shown during configuring network.
Comment 16 haiyang,dong 2012-10-12 06:04:36 EDT
(In reply to comment #15)
> Test version:
> rhev-hypervisor6-6.3-20121011.0.el6_3
> ovirt-node-2.3.0-15.el6_3.12
> 
> 1.clean install rhev-hypervisor6-6.3-20121011.0.el6_3,
> 2.enter network detail page and configure eth0 by using "DHCP", then press
> the "apply" button directly.
> 
> Configure eth0 success, no exception was shown during configuring network.

Also the issue about "No persistent udev rules w/ bisodevname" has been fixed on rhev-hypervisor6-6.3-20121011.0.el6_3
Comment 18 haiyang,dong 2012-10-12 06:49:53 EDT
According to comment 15 and comment 16, verified it.
Comment 20 errata-xmlrpc 2012-10-18 09:35:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1374.html

Note You need to log in before you can comment on or make changes to this bug.