Bug 864070 - The combination of zoom & full screen with remote-viewer leaves big black bars on top & bottom when zoom is 66 and lower
The combination of zoom & full screen with remote-viewer leaves big black ba...
Status: CLOSED DUPLICATE of bug 905898
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
x86_64 Windows
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 09:54 EDT by Vimal Patel
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-23 12:09:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2012-10-08 09:54:07 EDT
Description of problem:
When connecting to a a Win7 Guest with the latest qxl and virtio drivers using remote-viewer with the full screen option and the zoom option of 66 and below, the spice window appears full screen, but there are big black bars on the top and bottom of the screen.  

This seems very strange since doing full-screen and the zoom option of 67 shows up full screen with no black bars on the top or bottom.

Version-Release number of selected component (if applicable):
Win 7 Guest:
qxl-win-unsigned-0.1-15
virtio-win-prewhql-0.1-39

Win 7 Client:
mingw64-virt-viewer-0.5.3-11.el6.noarch

RHEL 6.3 Host:
Released version of 6.3 qemu-kvm & spice server


How reproducible:
100%

Steps to Reproduce:
1. remote-viewer --full-screen -zoom=<66 or lower> from mingw Win 7 64 client
2.
3.
  
Actual results:
full screen view of the guest with big black bars on the top and bottom of the screen.

Expected results:
full screen view of the guest 

Additional info:
Comment 1 Alon Levy 2013-04-04 05:29:47 EDT
Marc-Andre, can you take a look?
Comment 2 Marc-Andre Lureau 2013-04-04 07:59:37 EDT
Please try with a more recent mingw-virt-viewer build, mingw-virt-viewer-0.5.3-23.el6ev works for me.

Please try also with rhel6 virt-viewer.

It's probably not a driver bug. I am not sure that version of qxl driver has arbitrary resolution. I can't get the commit 100524f2478f3ee7a46774fe3841ce1449e3cfda from git://git.engineering.redhat.com/users/alevy/qxl.git

(http://download.devel.redhat.com/brewroot/packages/qxl-win-unsigned/0.1/15/data/logs/win/build.log)

It should be there, since the next build qxl-win-unsigned-0.1-16 has it.
Comment 3 Vimal Patel 2013-04-15 13:41:12 EDT
Tested this with the 
mingw-virt-viewer-0.5.3-23.el6ev on Windows 7 with a Windows 7 & RHEL 6,4 guests, and this works.

Can you add this to the mingw-virt-viewer errata and then change it to ON_QA?
Comment 4 Marc-Andre Lureau 2013-04-22 06:09:53 EDT
(In reply to comment #3)
> Tested this with the 
> mingw-virt-viewer-0.5.3-23.el6ev on Windows 7 with a Windows 7 & RHEL 6,4
> guests, and this works.
> 
> Can you add this to the mingw-virt-viewer errata and then change it to ON_QA?

Arbitrary resolution is part of the rebase for 3.2. And I am really not sure only mingw-virt-viewer fixed it, but rather an update of qxl or agent. I would rather just close that bug as current release.
Comment 5 Marc-Andre Lureau 2013-04-23 12:09:28 EDT

*** This bug has been marked as a duplicate of bug 905898 ***

Note You need to log in before you can comment on or make changes to this bug.