This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 905898 - Rebase mingw-virt-viewer in RHEV-M 3.2 to be on par with RHEL-6.4
Rebase mingw-virt-viewer in RHEV-M 3.2 to be on par with RHEL-6.4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Marc-Andre Lureau
Desktop QE
: Rebase
: 864070 905531 (view as bug list)
Depends On:
Blocks: 893090 894020 894350 894396
  Show dependency treegraph
 
Reported: 2013-01-30 07:18 EST by Uri Lublin
Modified: 2013-09-02 00:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.3-18.el6ev
Doc Type: Release Note
Doc Text:
A new native multiple monitor feature using a single QXL device for Red Hat Enterprise Linux virtual machines is included in the latest version of mingw-virt-viewer available in Red Hat Enterprise Virtualization 3.2. However, on Red Hat Enterprise Linux virtual machines multiple QXL devices are still created with not enough memory for a single QXL device, which can cause the multi-monitor feature to misbehave. To work around this issue, do not enable native multi-monitor support on your Linux virtual machines until this issue is fixed. Instead, use the Xinerama Xorg extension to manage Red Hat Enterprise Linux virtual machines with multi-monitor enabled.
Story Points: ---
Clone Of:
: 910880 (view as bug list)
Environment:
Last Closed: 2013-06-10 16:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Uri Lublin 2013-01-30 07:18:51 EST
Description of problem:
Implement the client side of spice seamless migration.

Related to bug 894020 and bug 894396
Comment 1 Uri Lublin 2013-01-30 09:48:51 EST
In addition to Live Migration the following features come with this rebase are:
- Multi-monitor support (single qxl)
- Native USB live migration
- Some bug fixes
Comment 2 Uri Lublin 2013-01-30 09:57:52 EST
*** Bug 905531 has been marked as a duplicate of this bug. ***
Comment 3 Bryan Yount 2013-02-08 18:02:08 EST
(In reply to comment #1)
> In addition to Live Migration the following features come with this rebase
> are:
> - Multi-monitor support (single qxl)
> - Native USB live migration
> - Some bug fixes

I have a couple of questions about this:
1) How is QXL implemented in Windows guests currently? Is it a single QXL or is it multiple? It looks like multiple to me.
2) If Windows uses multiple QXL, you're saying is that the current version of mingw-virt-viewer shipped with RHEV 3.1 does not support multi-monitor for Windows? That would be a pretty big regression.
Comment 4 Uri Lublin 2013-02-08 19:37:44 EST
(In reply to comment #3)
> (In reply to comment #1)
> > In addition to Live Migration the following features come with this rebase
> > are:
> > - Multi-monitor support (single qxl)
> > - Native USB live migration
> > - Some bug fixes
> 
> I have a couple of questions about this:
> 1) How is QXL implemented in Windows guests currently? Is it a single QXL or
> is it multiple? It looks like multiple to me.
> 2) If Windows uses multiple QXL, you're saying is that the current version
> of mingw-virt-viewer shipped with RHEV 3.1 does not support multi-monitor
> for Windows? That would be a pretty big regression.

For windows guests, there is no change. Multiple monitors require multiple QXL devices. The mingw-virt-viewer package in RHEV-3.1 supports this.

For Linux guests, a new feature was implemented in RHEL-6.4, which is multiple monitors with a single QXL device. The client side implementation of this feature will be pulled into RHEV-3.2 mingw-virt-viewer (actually most changes are in mingw-spice-gtk package) with this bug's rebase.
Comment 5 Bryan Yount 2013-02-10 19:37:59 EST
(In reply to comment #4)
> For windows guests, there is no change. Multiple monitors require multiple
> QXL devices. The mingw-virt-viewer package in RHEV-3.1 supports this.

Ok, thanks for clarifying this. In that case, I think we might have a different issue with the mingw-virt-viewer. On WinXP clients, if you have dual monitor configured for a Windows guest, every time you close virt-viewer and re-open it, you have to re-enable the 2nd display in the guest. I'll try to reproduce the issue and open a separate bug if needed. Thanks.
Comment 6 Uri Lublin 2013-02-12 07:44:23 EST
Another feature:
- HTTP Proxy support (ability to connect to the server via an HTTP proxy)
Comment 15 Marc-Andre Lureau 2013-04-23 12:09:28 EDT
*** Bug 864070 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2013-06-10 16:01:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0889.html

Note You need to log in before you can comment on or make changes to this bug.