This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 864352 - the guest was missed under "Hosted Virtual Systems " in rhn when configure RHN-register to the public RHN again
the guest was missed under "Hosted Virtual Systems " in rhn when configure RH...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: TestOnly
: 872717 (view as bug list)
Depends On: 872717 879148 902899 907847 913579
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 04:34 EDT by haiyang,dong
Modified: 2014-02-25 06:15 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
--no doc text required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 06:15:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-10-09 04:34:53 EDT
Description of problem:
At first,configure RHN-register to the public RHN,check that the guest is listed under "Hosted Virtual Systems " in rhn virtualization tab.
,but if i deleted the rhevh on RHN Web side and register rhevh to the public RHN again, check that info "No virtual systems." was shown on RHN Web side.


Version-Release number of selected component (if applicable):
rhev-hypervisor 6.3-20121005.0.rhev31.el6_3

How reproducible:
100%
 
Steps to Reproduce:
1.Install RHEV-H and register to RHN
2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
3.check RHN virtual systems section.
4.Then deleted the rhevh on RHN web side, and register rhevh to RHN again.
5.check RHN virtual systems section.

Actual result:
After step 3, check that the guest is listed under "Hosted Virtual Systems " in rhn virtualization tab.
After step 5, check that info "No virtual systems." was shown on RHN Web side.

Expect result:
After step 3 and 5, the guest should be listed under "Hosted Virtual Systems " in rhn virtualization tab.

Additional info:
Comment 4 haiyang,dong 2012-10-30 02:34:04 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Steps:
1.Install RHEV-H and register to RHN
2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
3.check RHN virtual systems section.
4.Then deleted the rhevh on RHN web side, and register rhevh to RHN again.
5.check RHN virtual systems section.

Result:
After step 3, check that there wasn't a list of virtual guests which are configured to run on rhev-h under "Hosted Virtual Systems " in rhn virtualization tab.
After step 5, check that info "No virtual systems." was shown on RHN Web side.

so this bug still exist, change the status into "ASSIGNED".
Comment 9 Mike Burns 2012-12-14 12:43:24 EST
*** Bug 872717 has been marked as a duplicate of this bug. ***
Comment 10 haiyang,dong 2013-01-22 00:55:05 EST
Test version:
rhev-hypervisor6-6.4-20130116.3.0.el6
ovirt-node-2.5.0-15.el6.noarch

Steps:
1.Install RHEV-H and register to RHN
2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
3.check RHN virtual systems section.
4.Then deleted the rhevh on RHN web side, and register rhevh to RHN again.
5.check RHN virtual systems section.

Result:
After step 3, check that the guest is listed under "Hosted Virtual Systems " in rhn virtualization tab
But After step 5, Still check that info "No virtual systems." was shown on RHN Web side.

Also After register rhev-h to rhn, run rhn-profile-sync:
[root@localhost admin]# rhn-profile-sync
Updating package profile...
Updating hardware profile...
Updating virtualization profile...
An error has occurred:
<type 'exceptions.TypeError'>
See /var/log/up2date for more information

[root@localhost admin]# cat /var/log/up2date 
[Tue Jan 22 05:47:43 2013] up2date updateLoginInfo() login info
[Tue Jan 22 05:47:43 2013] up2date logging into up2date server
[Tue Jan 22 05:47:44 2013] up2date successfully retrieved authentication token from up2date server
[Tue Jan 22 05:47:44 2013] up2date Updating package profile
[Tue Jan 22 05:47:51 2013] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn-profile-sync", line 56, in <module>
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 84, in run
  File "/usr/sbin/rhn-profile-sync", line 51, in main
    support.refresh(True)
  File "/usr/share/rhn/virtualization/support.py", line 82, in refresh
<type 'exceptions.TypeError'>: poll_through_vdsm() takes exactly 1 argument (0 given)

so this bug still exist, change the status into "ASSIGNED".
Comment 11 Fabian Deutsch 2013-01-22 11:49:11 EST
This seems like a problem in up2date. Added a new bug for it:

bug 902899 - rhn-profile-sync raises Exception
Comment 22 haiyang,dong 2013-10-23 07:34:54 EDT
Need to register rhev-h to RHEV-M and run some guests to check this bug has been fixed or not,But at present register rhev-h to RHEV-M failed, Having Bug 1019859 to track that issue,so need to waiting for Bug 1019859 fixed to verify this bug.
Comment 23 haiyang,dong 2013-10-31 04:25:47 EDT
Test version:
rhev-hypervisor6-6.5-20131029.0.el6ev.noarch.rpm
ovirt-node-3.0.1-6.el6.noarch


Tested as follows:
1.Install RHEV-H and register to RHN
2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
3.check RHN virtual systems section.

After step 3, Still check that info "No virtual systems." was shown on RHN Web side.

so need re-assigned this bug.

[root@dhcp-10-149 admin]# rhn-profile-sync 
Updating package profile...
Updating hardware profile...
Updating virtualization profile...
An error has occurred:
<type 'exceptions.TypeError'>
See /var/log/up2date for more information

[root@dhcp-10-149 admin]# rpm -qa |grep rhn-virtualization-host
rhn-virtualization-host-5.4.34-4.el6sat.noarch

For the rhn-profile-sync raises Exception, related bug 907847 has reported, seems it has been fixed in rhn-virtualization-5.4.34-5.el6sat
Comment 25 Fabian Deutsch 2014-02-21 08:50:08 EST
Dong,

could you please check if this bug still exists on a recent RHEV-H build?
Comment 28 haiyang,dong 2014-02-22 04:55:08 EST
(In reply to Fabian Deutsch from comment #25)
> Dong,
> 
> could you please check if this bug still exists on a recent RHEV-H build?

Test version:
rhev-hypervisor6-6.5-20140212.1.iso
ovirt-node-3.0.1-18.el6_5.6.noarch

Steps to Reproduce:
1.Install RHEV-H and register to RHN
2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
3.check RHN virtual systems section.
4.Then deleted the rhevh on RHN web side, and register rhevh to RHN again.
5.check RHN virtual systems section.

Test results:
After step 3 and 5, the guest could be listed under "Hosted Virtual Systems " in rhn virtualization tab.

so this bug has been fixed in rhev-hypervisor6-6.5-20140212.1.iso
Comment 29 Fabian Deutsch 2014-02-25 06:15:00 EST
Thanks Dong

Note You need to log in before you can comment on or make changes to this bug.