Bug 902899 - rhn-profile-sync raises Exception
rhn-profile-sync raises Exception
Status: CLOSED DUPLICATE of bug 907847
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027 864352
  Show dependency treegraph
 
Reported: 2013-01-22 11:48 EST by Fabian Deutsch
Modified: 2013-02-07 15:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 15:12:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-01-22 11:48:11 EST
Taken from #864352:

Description of problem:
(In reply to bug #864352 comment #10)
> Test version:
> rhev-hypervisor6-6.4-20130116.3.0.el6
> ovirt-node-2.5.0-15.el6.noarch
> 
> Steps:
> 1.Install RHEV-H and register to RHN
> 2.Run guest on top of RHEV-H host (prefer RHEL guest and configure network)
> 3.check RHN virtual systems section.
> 4.Then deleted the rhevh on RHN web side, and register rhevh to RHN again.
> 5.check RHN virtual systems section.
> 
> Result:
> After step 3, check that the guest is listed under "Hosted Virtual Systems "
> in rhn virtualization tab
> But After step 5, Still check that info "No virtual systems." was shown on
> RHN Web side.
> 
> Also After register rhev-h to rhn, run rhn-profile-sync:
> [root@localhost admin]# rhn-profile-sync
> Updating package profile...
> Updating hardware profile...
> Updating virtualization profile...
> An error has occurred:
> <type 'exceptions.TypeError'>
> See /var/log/up2date for more information
> 
> [root@localhost admin]# cat /var/log/up2date 
> [Tue Jan 22 05:47:43 2013] up2date updateLoginInfo() login info
> [Tue Jan 22 05:47:43 2013] up2date logging into up2date server
> [Tue Jan 22 05:47:44 2013] up2date successfully retrieved authentication
> token from up2date server
> [Tue Jan 22 05:47:44 2013] up2date Updating package profile
> [Tue Jan 22 05:47:51 2013] up2date 
> Traceback (most recent call last):
>   File "/usr/sbin/rhn-profile-sync", line 56, in <module>
>     cli.run()
>   File "/usr/share/rhn/up2date_client/rhncli.py", line 84, in run
>   File "/usr/sbin/rhn-profile-sync", line 51, in main
>     support.refresh(True)
>   File "/usr/share/rhn/virtualization/support.py", line 82, in refresh
> <type 'exceptions.TypeError'>: poll_through_vdsm() takes exactly 1 argument
> (0 given)
Comment 2 Jan Pazdziora 2013-01-23 02:54:58 EST
The /usr/share/rhn/virtualization/support.py is in rhn-virtualization-host, not rhn-client-tools, updating product and component.

It looks like bf4e0a4736186ea5473b425e23e55bf0c3420003 missed the support.py code path.
Comment 3 Jan Pazdziora 2013-01-23 02:56:02 EST
Any reason the comment 0 is private?
Comment 4 Fabian Deutsch 2013-01-23 03:42:09 EST
Jan,

(In reply to comment #3)
> Any reason the comment 0 is private?

nope - nothing to hide.
Comment 5 Jan Pazdziora 2013-01-23 03:47:44 EST
(In reply to comment #4)
> 
> nope - nothing to hide.

Flipping to public then.
Comment 6 Stephen Herr 2013-02-07 15:12:05 EST
Closing as duplicate of 907847. I know this one was filed first, but I just cloned the other one to spacewalk and it has a customer case.

*** This bug has been marked as a duplicate of bug 907847 ***

Note You need to log in before you can comment on or make changes to this bug.