This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864710 - Does not support mass-installing via a command-line wildcard (QueryException: Query unsupported in this context.)
Does not support mass-installing via a command-line wildcard (QueryException:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:37ee175234b85f0bc718c0a4e5d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 19:49 EDT by scorpio
Modified: 2014-09-30 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.2.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (519 bytes, text/plain)
2012-10-09 19:49 EDT, scorpio
no flags Details

  None (edit)
Description scorpio 2012-10-09 19:49:43 EDT
Description of problem:
Trying to install thunderbird-lightning package using cmd "dnf install thunderbird-lightning*"

Version-Release number of selected component:
dnf-0.2.13-1.gitda60a96.fc18

Additional info:
libreport version: 2.0.15
abrt_version:   2.0.14
cmdline:        /usr/bin/python /bin/dnf install thunderbird-lightning*
kernel:         3.6.1-1.fc18.x86_64

backtrace:
:__init__.py:865:buildHawkeyGoal:QueryException: Query unsupported in this context.
:
:Traceback (most recent call last):
:  File "/bin/dnf", line 35, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/lib/python2.7/site-packages/dnf/cli/yummain.py", line 316, in user_main
:    errcode = main(args)
:  File "/usr/lib/python2.7/site-packages/dnf/cli/yummain.py", line 181, in main
:    (result, resultmsgs) = base.buildTransaction()
:  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 897, in buildTransaction
:    goal = self.buildHawkeyGoal(self.tsInfo)
:  File "/usr/lib/python2.7/site-packages/dnf/yum/__init__.py", line 865, in buildHawkeyGoal
:    goal.install(query=q)
:QueryException: Query unsupported in this context.
:
:Local variables in innermost frame:
:q: <hawkey.Query object at 0x1723af0>
:tsInfo: <dnf.yum.transactioninfo.TransactionData instance at 0x1444170>
:self: <dnf.cli.cli.YumBaseCli object at 0x143db90>
:goal: <hawkey.Goal object at 0x1723cd0>
:push_userinstalled: False
Comment 1 scorpio 2012-10-09 19:49:46 EDT
Created attachment 624336 [details]
File: core_backtrace
Comment 2 Ales Kozumplik 2012-10-12 06:57:20 EDT
Hello and thank you for the bug report.

DNF does not yet support using wildcards with the install command. I am looking into adding the feature now.
Comment 3 scorpio 2012-10-12 07:48:01 EDT
Hello, great job anyway.
DNF lets me install a package easily that caused me unsolved dependencies with yum since weeks.
Comment 4 Ales Kozumplik 2012-10-17 08:11:07 EDT
(In reply to comment #3)
> Hello, great job anyway.
> DNF lets me install a package easily that caused me unsolved dependencies
> with yum since weeks.

Thanks, I am glad to hear that:)
Comment 5 Ales Kozumplik 2012-10-17 08:12:55 EDT
The wildcard support in installs has been added by commit 1706fce.
Comment 6 Fedora Update System 2012-10-17 13:30:01 EDT
dnf-0.2.14-2.git4831982.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dnf-0.2.14-2.git4831982.fc18
Comment 7 Fedora Update System 2012-10-17 23:34:29 EDT
Package dnf-0.2.14-2.git4831982.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.2.14-2.git4831982.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16373/dnf-0.2.14-2.git4831982.fc18
then log in and leave karma (feedback).
Comment 8 scorpio 2012-10-21 15:04:22 EDT
(In reply to comment #5)
> The wildcard support in installs has been added by commit 1706fce.

Works nice even on update
What's the equivalent of the "yum check-update" command? It does not accept it and i do not find in the help...

Thanks for the work
Comment 9 Ales Kozumplik 2012-10-22 04:16:29 EDT
> What's the equivalent of the "yum check-update" command? It does not accept
> it and i do not find in the help...

Hello, this has not been implemented yet---I've opened bug 864710 for it.
Comment 10 Ales Kozumplik 2012-10-22 04:20:15 EDT
> Hello, this has not been implemented yet---I've opened bug 864710 for it.

Sorry, that should be bug 868810.
Comment 11 Fedora Update System 2012-12-20 10:25:57 EST
dnf-0.2.14-2.git4831982.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.