Bug 864764 - KickstartValueError: The following problem occurred on line 80 of the kickstart file: Tried to use undefined partition raid.21 in RAID specification
KickstartValueError: The following problem occurred on line 80 of the kicksta...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:c17b2511b744e38e390647d6bad...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 00:32 EDT by digimer
Modified: 2013-05-22 15:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 15:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: release (24 bytes, text/plain)
2012-10-10 00:32 EDT, digimer
no flags Details
File: product (6 bytes, text/plain)
2012-10-10 00:32 EDT, digimer
no flags Details
File: type (9 bytes, text/plain)
2012-10-10 00:32 EDT, digimer
no flags Details
File: storage.log (5.21 MB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: version (11 bytes, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: environ (853 bytes, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: anaconda.log (84.07 KB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: syslog (125.81 KB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: packaging.log (1.63 KB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: cmdline_file (184 bytes, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: ks.cfg (4.80 KB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: anaconda-tb (245.33 KB, text/plain)
2012-10-10 00:33 EDT, digimer
no flags Details
File: program.log (1.98 MB, text/plain)
2012-10-10 00:34 EDT, digimer
no flags Details
kickstart file which generates "undefined partition" error (3.08 KB, application/octet-stream)
2013-02-13 13:35 EST, John Faichney
no flags Details
ks.cfg - fixed bugzilla content-type (3.08 KB, text/plain)
2013-02-13 13:36 EST, John Faichney
no flags Details

  None (edit)
Description digimer 2012-10-10 00:32:34 EDT
Description of problem:
Tried to install from kickstart a system with software RAID level 1. Tried numerous incarnations, starting with a ks script that worked up to F17.

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1153, in execute
:    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Tried to use undefined partition %s in RAID specification" % mem)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1082, in execute
:    r.execute(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1559, in doKickstartStorage
:    ksdata.raid.execute(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 379, in _doExecute
:    doKickstartStorage(self.storage, self.data, self.instclass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:KickstartValueError: The following problem occurred on line 80 of the kickstart file:
:
:Tried to use undefined partition raid.21 in RAID specification
:
Comment 1 digimer 2012-10-10 00:32:38 EDT
Created attachment 624537 [details]
File: release
Comment 2 digimer 2012-10-10 00:32:39 EDT
Created attachment 624538 [details]
File: product
Comment 3 digimer 2012-10-10 00:32:41 EDT
Created attachment 624539 [details]
File: type
Comment 4 digimer 2012-10-10 00:33:38 EDT
Created attachment 624540 [details]
File: storage.log
Comment 5 digimer 2012-10-10 00:33:40 EDT
Created attachment 624541 [details]
File: version
Comment 6 digimer 2012-10-10 00:33:42 EDT
Created attachment 624542 [details]
File: environ
Comment 7 digimer 2012-10-10 00:33:44 EDT
Created attachment 624543 [details]
File: anaconda.log
Comment 8 digimer 2012-10-10 00:33:46 EDT
Created attachment 624544 [details]
File: syslog
Comment 9 digimer 2012-10-10 00:33:48 EDT
Created attachment 624545 [details]
File: hashmarkername
Comment 10 digimer 2012-10-10 00:33:50 EDT
Created attachment 624546 [details]
File: packaging.log
Comment 11 digimer 2012-10-10 00:33:51 EDT
Created attachment 624547 [details]
File: cmdline_file
Comment 12 digimer 2012-10-10 00:33:53 EDT
Created attachment 624548 [details]
File: ks.cfg
Comment 13 digimer 2012-10-10 00:33:57 EDT
Created attachment 624549 [details]
File: anaconda-tb
Comment 14 digimer 2012-10-10 00:34:19 EDT
Created attachment 624550 [details]
File: program.log
Comment 15 Fedora Update System 2012-10-10 21:04:57 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 16 Fedora Update System 2012-10-10 22:58:33 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-10-11 21:06:49 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 18 Fedora Update System 2012-10-16 23:09:48 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 19 Fedora Update System 2012-10-17 22:38:38 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 20 Fedora Update System 2012-10-19 21:34:28 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 21 Adam Williamson 2012-11-22 23:01:33 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.
Comment 22 John Faichney 2013-02-13 13:33:45 EST
Please, can this bug be re-opened?  I am finding exactly this behaviour with anaconda-18.37.11 (that is, anaconda as bundled w/ Fedora 18 on 20130115.)

Symptoms are identical to what is described above and (in a non-raid context) here: https://bugzilla.redhat.com/show_bug.cgi?id=853649#c17 - that is,

     1. partitions and raid are defined in the kickstart file
          part /boot --fstype="ext4" blah blah
          part swap --fstype="swap" blah blah
          part raid.01 --grow blah blah
          part raid.02 --grow blah blah
          raid pv.01 --level=0 --device=md0 --fstype=ext4 raid.01 raid.02

     2. anaconda reports "Tried to use undefined partition raid.01 in RAID specification"

     3. the 'ksdata' section of anaconda's diagnostic output shows that *raid-relevant* identifiers have disappeared from their corresponding options:
          part /boot --fstype="ext4" blah blah
          part  --fstype="swap" blah blah
          part  --grow blah blah
          part  --grow blah blah
          raid --device=0 --fstype="ext4" --level=RAID0 raid.01 raid.02

The 'swap' identified has also disappeared, but apparently this does not generate an error.

The kickstart file which generated this error is attached, see below.
Comment 23 John Faichney 2013-02-13 13:35:24 EST
Created attachment 696996 [details]
kickstart file which generates "undefined partition" error
Comment 24 John Faichney 2013-02-13 13:36:36 EST
Created attachment 696998 [details]
ks.cfg - fixed bugzilla content-type
Comment 25 Adam Williamson 2013-02-14 21:37:53 EST
Re-opening per John's comments, clearing Fixed-in-Version field.
Comment 26 Chris Lumens 2013-05-22 15:29:44 EDT
I cannot reproduce this with anaconda-19.30.  If you are able to do so with Fedora 19, please feel free to reopen this bug with your kickstart file and anaconda logs.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.