Bug 864790 - Validator marks boundary event by "Node has no incoming connections"
Validator marks boundary event by "Node has no incoming connections"
Status: CLOSED DUPLICATE of bug 864794
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kris Verlaenen
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 03:04 EDT by Sona Mala
Modified: 2012-10-10 03:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 03:21:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2012-10-10 03:04:37 EDT
Description of problem:
Validator marks boundary event by alert "Node has no incoming connection". For the boundary event, there is an attribute "attachedToRef" instead of attribute "incoming connection". From BPMN 2 definition: "If the Intermediate Event is attached to the boundary of an Activity then the Intermediate Event MUST NOT be a target for a Sequence Flow; it cannot have an incoming Sequence Flows."


Version-Release number of selected component (if applicable):
BRMS 5.3.1 ER1(ER2) and designer 2.3.1-DEV

How reproducible:
When attach any event to activity as boundary event

Steps to Reproduce:
 1. clear a repository (or import idle repository)
 2. create new process (call sub-process)
       Start->Task->XORgateway->End
                        |->Error
 3. validate process (create PNG, set property "ErrorRef" for Error End Event)
 4. save and close process
 5. create new process (call boundaryevent)
       Start->ReusableSubprocess With BoundaryEvent->End
 6. create PNG image, set property "ErrorRef" for boundary error event, set property "Called Element" for Reusable Subprocess
 7. validate
  
Actual results:
Validation marks boundary event

Expected results:
Alert "There are no validation errors"

Additional info:
<bpmn2:boundaryEvent xmlns:bpmn2="http://www.omg.org/spec/BPMN/20100524/MODEL" id="_88B653A2-3371-40BC-A100-28CF073B7256" drools:bgcolor="#f5deb3" xmlns:drools="http://www.jboss.org/drools" drools:selectable="true" drools:bordercolor="#a0522d" drools:boundaryca="false" name="" attachedToRef="_F206DAF8-C0B6-4D9B-A1EC-DB381B0A1F96" cancelActivity="false">
      <bpmn2:outgoing>_C85DB60A-72BB-40FC-85EE-7634269409CF</bpmn2:outgoing>
      <bpmn2:errorEventDefinition id="_yThN4RIgEeKS37fzgw701A" errorRef="_yThN4hIgEeKS37fzgw701A"/>
    </bpmn2:boundaryEvent>
Comment 1 Sona Mala 2012-10-10 03:21:08 EDT

*** This bug has been marked as a duplicate of bug 864794 ***

Note You need to log in before you can comment on or make changes to this bug.