Bug 864794 - Validator marks boundary event by "Node has no incoming connections"
Validator marks boundary event by "Node has no incoming connections"
Status: CLOSED DUPLICATE of bug 852114
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tihomir Surdilovic
Sona Mala
:
: 864790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 03:16 EDT by Sona Mala
Modified: 2012-11-05 18:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 09:18:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kverlaen: needinfo+


Attachments (Terms of Use)
Repository with BPMN2 processes (217.27 KB, text/xml)
2012-10-18 04:13 EDT, Sona Mala
no flags Details
process in repo (34.89 KB, image/png)
2012-10-18 08:01 EDT, Tihomir Surdilovic
no flags Details
BPMN2 process image (45.80 KB, image/png)
2012-10-18 08:40 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2012-10-10 03:16:29 EDT
Description of problem:
Validator marks boundary event by alert "Node has no incoming connection". For the boundary event, there is an attribute "attachedToRef" instead of attribute "incoming connection". From BPMN 2 definition: "If the Intermediate Event is attached to the boundary of an Activity then the Intermediate Event MUST NOT be a target for a Sequence Flow; it cannot have an incoming Sequence Flows."


Version-Release number of selected component (if applicable):
BRMS 5.3.1 ER1(ER2) and designer 2.3.1-DEV

How reproducible:
When attach any event to activity as boundary event

Steps to Reproduce:
 1. clear a repository (or import idle repository)
 2. create new process (call sub-process)
       Start->Task->XORgateway->End
                        |->Error
 3. validate process (create PNG, set property "ErrorRef" for Error End Event)
 4. save and close process
 5. create new process (call boundaryevent)
       Start->ReusableSubprocess With BoundaryEvent->End
 6. create PNG image, set property "ErrorRef" for boundary error event, set property "Called Element" for Reusable Subprocess
 7. validate
  
Actual results:
Validation marks boundary event

Expected results:
Alert "There are no validation errors"

Additional info:
<bpmn2:boundaryEvent xmlns:bpmn2="http://www.omg.org/spec/BPMN/20100524/MODEL" id="_88B653A2-3371-40BC-A100-28CF073B7256" drools:bgcolor="#f5deb3" xmlns:drools="http://www.jboss.org/drools" drools:selectable="true" drools:bordercolor="#a0522d" drools:boundaryca="false" name="" attachedToRef="_F206DAF8-C0B6-4D9B-A1EC-DB381B0A1F96" cancelActivity="false">
      <bpmn2:outgoing>_C85DB60A-72BB-40FC-85EE-7634269409CF</bpmn2:outgoing>
      <bpmn2:errorEventDefinition id="_yThN4RIgEeKS37fzgw701A" errorRef="_yThN4hIgEeKS37fzgw701A"/>
    </bpmn2:boundaryEvent>
Comment 1 Sona Mala 2012-10-10 03:21:08 EDT
*** Bug 864790 has been marked as a duplicate of this bug. ***
Comment 2 Tihomir Surdilovic 2012-10-11 17:50:18 EDT
Could you please attach the bpmn2 or the images of both of these processes?
Comment 3 Sona Mala 2012-10-18 04:13:35 EDT
Created attachment 629227 [details]
Repository with BPMN2 processes
Comment 4 Tihomir Surdilovic 2012-10-18 08:00:56 EDT
What I am supposed to test in the attached repo? When I open the process called "process" it does not look correct (will attach image). The process called "subprocess" does not include any boundary events.

thanks.
Comment 5 Tihomir Surdilovic 2012-10-18 08:01:35 EDT
Created attachment 629330 [details]
process in repo
Comment 6 Sona Mala 2012-10-18 08:40:29 EDT
Created attachment 629354 [details]
BPMN2 process image
Comment 7 Sona Mala 2012-10-18 08:46:15 EDT
I import repository and everything is normal. You can see it on attached image.
Comment 8 Tihomir Surdilovic 2012-10-18 08:57:23 EDT
Thanks, setting boundary events on call activities has been disabled in the community . I am looking for a JIRA and then will backport that to 2.3.x branch.
Comment 9 Tihomir Surdilovic 2012-10-18 09:03:31 EDT
Ok, this BX should be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=852114

https://bugzilla.redhat.com/show_bug.cgi?id=852114 however has been set to FUTURE, even tho it has a blocker+ flag. I don't know what to do. The fix for https://bugzilla.redhat.com/show_bug.cgi?id=852114 needs to be applied to fix this BZ...let me know what to do.
Comment 10 Lukáš Petrovický 2012-10-18 09:18:35 EDT

*** This bug has been marked as a duplicate of bug 852114 ***

Note You need to log in before you can comment on or make changes to this bug.