This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864939 - Note that systemctl now assumes ".service"
Note that systemctl now assumes ".service"
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2012-10-10 08:48 EDT by Matthew Miller
Modified: 2013-05-14 20:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 20:52:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-10 08:48:49 EDT
Provide details here.  Do not change the blocking bug.

Previously, systemd required services to have .service appended in systemctl commands;

$ sudo systemctl restart myservice
$ Failed to issue method call: Unit name myservice is not valid.
-bash: Failed: command not found
$ sudo systemctl restart myservice.service
[okay]

Starting with F18, if there is no dot suffix, systemctl will assume you meant a service and just work.

This should go in the release notes, because it's a common end-user complaint about the systemctl user interface.
Comment 1 Pete Travis 2012-10-19 08:35:52 EDT
Added to the server configuration tools beat.

Thanks, Matthew!

Note You need to log in before you can comment on or make changes to this bug.