Bug 864943 - installed groups are listed as available
installed groups are listed as available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
18
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 08:56 EDT by Jeff Bastian
Modified: 2014-03-16 23:32 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 08:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of gnome apparently not installed (116.78 KB, image/png)
2012-10-12 11:47 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2012-10-10 08:56:37 EDT
Description of problem:
yum grouplist shows installed groups as "Available Environment Groups".  Trying to install them doesn't do anything because they're already installed.

# yum grouplist
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit,
              : verify
Available Environment Groups:
   GNOME Desktop
   ...

# yum -y groupinstall 'GNOME Desktop'
...
No packages in any requested group available to install or update

(See below for full output)


Version-Release number of selected component (if applicable):
Fedora 18
yum-3.4.3-45.fc18.noarch

How reproducible:
every time

Steps to Reproduce:
1. yum grouplist available
2. pick an available group
3. yum groupinstall 'Some Available Group'
  
Actual results:
nothing -- because the group is already fully installed

Expected results:
the group is listed in the "Installed Groups" section (not Available)

Additional info:

# yum grouplist available
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit,
              : verify
Available Environment Groups:
   GNOME Desktop
   KDE Desktop
   Xfce Desktop
   LXDE Desktop
   Sugar Desktop Environment
   Development and Creative Workstation
   Web Server
   Infrastructure Server
   Basic X windows
   Minimal install
Available Groups:
   Books and Guides
   Engineering and Scientific
   Fedora Eclipse
   LibreOffice
   Medical Applications
   Web Development
Done

# yum -y groupinstall 'GNOME Desktop'
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit,
              : verify
Warning: Group core does not have any packages to install.
Warning: Group gnome-desktop does not have any packages to install.
Package gstreamer1-plugins-bad-free-1.0.0-2.fc18.x86_64 already installed and latest version
Package gstreamer1-plugins-good-1.0.0-1.fc18.x86_64 already installed and latest version
Warning: Group multimedia does not have any packages to install.
Warning: Group firefox does not have any packages to install.
Warning: Group base-x does not have any packages to install.
Warning: Group fonts does not have any packages to install.
Warning: Group hardware-support does not have any packages to install.
Warning: Group dial-up does not have any packages to install.
Warning: Group printing does not have any packages to install.
Package imsettings-lxde-1.3.1-1.fc18.x86_64 already installed and latest version
Package gtk2-immodule-xim-2.24.13-1.fc18.x86_64 already installed and latest version
Package ibus-qt-1.3.1-10.fc18.x86_64 already installed and latest version
Package im-chooser-xfce-1.6.0-3.fc18.x86_64 already installed and latest version
Package imsettings-gnome-1.3.1-1.fc18.x86_64 already installed and latest version
Package ibus-gtk3-1.4.99.20120914-2.fc18.x86_64 already installed and latest version
Package ibus-gtk2-1.4.99.20120914-2.fc18.x86_64 already installed and latest version
Package gtk3-immodule-xim-3.6.0-1.fc18.x86_64 already installed and latest version
Package imsettings-xfce-1.3.1-1.fc18.x86_64 already installed and latest version
Package imsettings-qt-1.3.1-1.fc18.x86_64 already installed and latest version
Warning: Group input-methods does not have any packages to install.
Package chrony-1.27-0.5.pre1.git1ca844.fc18.x86_64 already installed and latest version
Warning: Group standard does not have any packages to install.
No packages in any requested group available to install or update
Comment 1 Jeff Bastian 2012-10-10 09:05:04 EDT
Following down the dependency chain, I'm seeing some packages that appear to be missing.

# yum group info 'GNOME Desktop'
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit,
              : verify

Environment Group: GNOME Desktop
 Environment-Id: gnome-desktop
 Description: GNOME is a highly intuitive and user friendly desktop environment.
 Mandatory Groups:
   base-x
   core
   ...

Ok, the core group should be installed, right?

# yum group list available ids hidden | grep -i core
   Core (core)

Hmm, even the Core group is not installed?

# yum group info -v @core
...
 Mandatory Packages:
   ...
   iproute-3.6.0-2.fc18.x86_64                                  @fedora         
   iprutils
   iputils-20101006-18.fc18.x86_64                              @updates-testing
   ...

Why doesn't iprutils have a yum repo?

# yum list iprutils
...
Error: No matching Packages to list

So, the Core group is missing iprutils, therefore it's not fully installed, and therefore Gnome Desktop is not fully installed either.

I wonder if other groups are missing packages?
Comment 2 Jeff Bastian 2012-10-10 09:29:44 EDT
I hacked together a quick script (see below) and found the following groups are missing mandatory packages:

gnome-desktop
   PackageKit-gtk-module
   gnome-disk-utility-nautilus
xfce-desktop
   xfce-utils
sugar-desktop
   sugar-cp-all
developer-workstation
   Warning: Group/Environment developer-workstation does not exist.
infrastructure-server
   Warning: Group/Environment infrastructure-server does not exist.
basic-x-windows
   Warning: Group/Environment basic-x-windows does not exist.
minimal
   Warning: Group/Environment minimal does not exist.
admin-tools
   ettercap-gtk
cloud-infrastructure
   pacemaker-cloud
development-tools
   ipython
hardware-support
   s3switch
input-methods
   scim-mozc
multimedia
   gstreamer1-plugins-espeak
system-tools
   vbetool
anaconda-tools
   s390utils
   s390utils-base
   silo
   uboot-beagle
   uboot-origen
   uboot-panda
   yaboot
gnome-apps
   evolution-NetworkManager
xfce-apps
   clipman
core
   iprutils
   ppc64-utils
development-libs
   db4-devel
dogtag
   pki-common-javadoc
   pki-java-tools-javadoc
   pki-util-javadoc
gnome-desktop
   PackageKit-gtk-module
   gnome-disk-utility-nautilus
legacy-software-support
   compat-db
sugar-desktop
   sugar-cp-all
xfce-desktop
   xfce-utils
base-x
   xorg-x11-drv-geode
   xorg-x11-drv-omap


Quick hack to find groups with missing packages.  (The output above has been edited to make it shorter.)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#!/bin/bash

yum group list installed available environment hidden ids packages | \
    grep ')$' | awk '{print $NF}' | tr -d '()' > /tmp/yum-groups

for g in $(cat /tmp/yum-groups) ; do
  echo "~~~"
  echo $g
  yum group info -v @${g} | grep '^   ' | awk '{ if (NF == 1) { print $0 } }'
  echo ""
done
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Comment 3 Jeff Bastian 2012-10-10 09:46:51 EDT
It looks like the problem is in the comps file.  I can see the missing packages listed for the various groups in my yum cache:
  /var/cache/yum/x86_64/18/fedora/*-comps-f18.xml.gz

I did a 'yum clean all' and verified the comps file was removed, and checked the yum groups again, and the problem is still present.
Comment 4 James Antill 2012-10-11 16:05:30 EDT
 Yeh, that's how non-object groups are supposed to work (or at least have traditionally, and it's really annoying to get the information that the packages aren't available to the bit that looks if the groups are installed IIRC).

 Sometimes I've seen this it's because the package is only available on certain arches ... but that can be worked around by playing with mandatory/default/optional or using deps. etc.

 Moving to comps.
Comment 5 Bill Nottingham 2012-10-12 10:18:40 EDT
Environment groups aren't groups; they are a list of groups.

Some of them do share the name with existing actual groups - if that is a problem, we can adjust it.
Comment 6 Jeff Bastian 2012-10-12 11:47:16 EDT
Created attachment 626074 [details]
screenshot of gnome apparently not installed

The problem is it's confusing to the end user when it appears that groups -- environment or regular -- appear as not installed.

This propagates up to the PackageKit GUI also. 
 - Start the Software program
 - go to Package Collections
 - notice that GNOME Desktop Environment is unchecked
 - click checkbox for GNOME Desktop Environment and hit Apply Changes
 - when it finishes installing GNOME, restart the Software program
 - go to Package collections
 - hey, GNOME is unchecked!  but I just installed it!
Comment 7 Bill Nottingham 2012-10-12 13:48:40 EDT
Some of that may be due to the name clash mentioned above in comment #5.
Comment 8 Bill Nottingham 2012-10-16 22:55:25 EDT
OK, I have pushed a variety of changes to comps that should make behavior better here.

1) I've fixed it so that groups and environments no longer have the same names or IDs.
2) I've edited the categories so that options available in anaconda should be available post-install.
Comment 9 Bill Nottingham 2012-10-16 22:56:09 EDT
Due to how comps work, you'll likely not see these changes clearly until all of the following have happened:

1) a new nightly tree is pushed
2) a new updates push is done
3) a full PK refresh is done
Comment 10 Cole Robinson 2013-10-08 08:22:11 EDT
Sounds like it's long since fixed
Comment 11 Matthew 2013-12-13 11:25:48 EST
This bug appears to have come back on my system within the last 2 days after I picked up 205 Mb of updates.

I'm running Fedora 19.  Apper shows no updates are required now, but If I run Yum update it shows the following warnings, then that there are no updates.

Loaded plugins: langpacks, refresh-packagekit
Warning: group core does not exist.
Warning: group gnome-desktop does not exist.
Warning: group multimedia does not exist.
Warning: group firefox does not exist.
Warning: group guest-desktop-agents does not exist.
Warning: group base-x does not exist.
Warning: group anaconda-tools does not exist.
Warning: group fonts does not exist.
Warning: group hardware-support does not exist.
Warning: group dial-up does not exist.
Warning: group printing does not exist.
Warning: group kde-desktop does not exist.
Warning: group libreoffice does not exist.
Warning: group input-methods does not exist.
Warning: group standard does not exist.
No packages marked for update

I just installed gnome-desktop again and still it shows it as missing.

Where could all those packages have gone?
Comment 12 Jan Zeleny 2013-12-16 03:01:45 EST
That might be a different problem, check out whether your problem doesn't fit one of the other bugzillas we have currently open for yum groups.

Note You need to log in before you can comment on or make changes to this bug.