Bug 865048 - kickstarted install can't autopart disk
kickstarted install can't autopart disk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-10 13:05 EDT by Kamil Páral
Modified: 2012-10-23 09:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 09:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg (900 bytes, text/plain)
2012-10-10 13:16 EDT, Kamil Páral
no flags Details
anaconda.log (732.74 KB, text/plain)
2012-10-10 13:16 EDT, Kamil Páral
no flags Details
packaging.log (2.28 KB, text/plain)
2012-10-10 13:17 EDT, Kamil Páral
no flags Details
program.log (21.98 MB, text/plain)
2012-10-10 13:17 EDT, Kamil Páral
no flags Details
storage.log (40.32 MB, text/plain)
2012-10-10 13:19 EDT, Kamil Páral
no flags Details
syslog (394.65 KB, text/plain)
2012-10-10 13:19 EDT, Kamil Páral
no flags Details
X.log (55.65 KB, text/plain)
2012-10-10 13:19 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-10 13:05:54 EDT
Description of problem:
I have done a default DVD installation. Then I took anaconda-ks.cfg and performed the same installation, but this time kickstarted. This should be a fully unattended installation. Instead, the main hub appeared with errors in the partitioning spoke. After clicking on details, I see:
"Not enough free space on disks for automatic partitioning"

The kickstart contains:
# System bootloader configuration
bootloader --location=mbr --boot-drive=vda
autopart --type=plain
# Partition clearing information
clearpart --none --initlabel --drives=vda


I also tried a different kickstart, which contains:
# Wipe all disk
zerombr
bootloader --append="console=ttyS0" --timeout=1
clearpart --all --initlabel
part biosboot --fstype=biosboot --size=1
part swap --fstype=swap --size=512
part / --fstype=ext4 --grow --size=1
That didn't work either.

Version-Release number of selected component (if applicable):
F18 Beta TC3 DVD
anaconda 18.14

How reproducible:
seems always

Steps to Reproduce:
1. Take anaconda-ks.cfg from a default installation
2. Run kickstarted installation with it
3. Except unattended install, be surprised
Comment 1 Kamil Páral 2012-10-10 13:16:54 EDT
Created attachment 625043 [details]
anaconda-ks.cfg
Comment 2 Kamil Páral 2012-10-10 13:16:58 EDT
Created attachment 625044 [details]
anaconda.log
Comment 3 Kamil Páral 2012-10-10 13:17:01 EDT
Created attachment 625045 [details]
packaging.log
Comment 4 Kamil Páral 2012-10-10 13:17:24 EDT
Created attachment 625046 [details]
program.log
Comment 5 Kamil Páral 2012-10-10 13:19:15 EDT
Created attachment 625047 [details]
storage.log
Comment 6 Kamil Páral 2012-10-10 13:19:38 EDT
Created attachment 625048 [details]
syslog
Comment 7 Kamil Páral 2012-10-10 13:19:42 EDT
Created attachment 625049 [details]
X.log
Comment 8 Kamil Páral 2012-10-10 13:21:10 EDT
Proposing as Beta blocker:
" The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 9 Chris Lumens 2012-10-10 14:18:17 EDT
Well, "clearpart --none --initlabel --drives=" isn't going to have any effect.  According to the kickstart docs, --initlabel only means something if used with --all.  But perhaps you've got enough free space so it doesn't really matter.

However, there is definitely a kickstart-specific partitioning bug here that I can reproduce with your second test up there.  Sending off a patch...
Comment 10 Fedora Update System 2012-10-10 21:04:51 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.15-1.fc18
Comment 11 Fedora Update System 2012-10-10 22:58:24 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15903/anaconda-18.15-1.fc18
then log in and leave karma (feedback).
Comment 12 Adam Williamson 2012-10-11 13:16:20 EDT
Discussed at 2012-10-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-11/f18beta-blocker-review-3.1.2012-10-11-16.04.log.txt . We agreed that it's slightly unclear what's going on here, but whatever it is, it seems pretty clearly a violation of "The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible" , so it's accepted as a blocker. Chris, if you think we're off, please say so :)
Comment 13 Jesse Keating 2012-10-11 13:36:37 EDT
With an updates.img made of the fix I'm no longer seeing problems with kickstart in graphical mode.  I would consider this VERIFIED.
Comment 14 Fedora Update System 2012-10-11 21:06:40 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 15 Kamil Páral 2012-10-15 08:02:02 EDT
This is fixed in Beta TC4 (but due to bug 866449 the kickstarted installation still doesn't finish successfully).
Comment 16 Fedora Update System 2012-10-16 23:09:42 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 17 Fedora Update System 2012-10-17 13:31:25 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 18 Adam Williamson 2012-10-17 20:09:34 EDT
Back to VERIFIED.
Comment 19 Fedora Update System 2012-10-17 22:38:32 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 20 Fedora Update System 2012-10-18 11:31:06 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-10-19 21:34:22 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 22 Fedora Update System 2012-10-19 23:52:27 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 23 Kamil Páral 2012-10-23 09:05:44 EDT
Fixed, anaconda stable, closing.

Note You need to log in before you can comment on or make changes to this bug.