Bug 866449 - kickstart install hangs at "Writing network configuration"
kickstart install hangs at "Writing network configuration"
Status: CLOSED DUPLICATE of bug 866434
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-15 07:57 EDT by Kamil Páral
Modified: 2012-10-15 10:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 10:49:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback (15.91 KB, image/png)
2012-10-15 07:58 EDT, Kamil Páral
no flags Details
screenshot (20.95 KB, image/png)
2012-10-15 07:58 EDT, Kamil Páral
no flags Details
anaconda.log (6.61 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
anaconda-yum.conf (243 bytes, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
packaging.log (195.80 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
program.log (43.45 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
storage.log (117.46 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
syslog (87.61 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details
X.log (55.66 KB, text/plain)
2012-10-15 07:59 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-15 07:57:25 EDT
Description of problem:
This might and might not be related to bug 862801 and bug 866434.

I performed kickstarted installation twice, every time it hangs at "Writing network configuration" step. But it does not hog cpu at 100%, it is idle.

There are six (!) anaconda-tb-* files, all of them are empty. The traceback is shown only at anaconda main console.

Version-Release number of selected component (if applicable):
F18 Beta TC4 DVD i386
anaconda 18.16

How reproducible:
2 out of 2

Steps to Reproduce:
1. run kickstarted installation
2. see it hang at "Writing network configuration"
Comment 1 Kamil Páral 2012-10-15 07:58:28 EDT
Created attachment 627356 [details]
traceback
Comment 2 Kamil Páral 2012-10-15 07:58:34 EDT
Created attachment 627357 [details]
screenshot
Comment 3 Kamil Páral 2012-10-15 07:59:03 EDT
Created attachment 627358 [details]
anaconda.log
Comment 4 Kamil Páral 2012-10-15 07:59:07 EDT
Created attachment 627359 [details]
anaconda-yum.conf
Comment 5 Kamil Páral 2012-10-15 07:59:37 EDT
Created attachment 627360 [details]
packaging.log
Comment 6 Kamil Páral 2012-10-15 07:59:41 EDT
Created attachment 627361 [details]
program.log
Comment 7 Kamil Páral 2012-10-15 07:59:44 EDT
Created attachment 627362 [details]
storage.log
Comment 8 Kamil Páral 2012-10-15 07:59:48 EDT
Created attachment 627363 [details]
syslog
Comment 9 Kamil Páral 2012-10-15 07:59:52 EDT
Created attachment 627364 [details]
X.log
Comment 10 Kamil Páral 2012-10-15 08:00:54 EDT
Proposing as Beta blocker:
 The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible 
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 11 Radek Vykydal 2012-10-15 10:36:24 EDT
For the record, NM crash same as in bug 866434 in syslog:

10:59:48,074 INFO kernel:[  796.226748] NetworkManager[1100]: segfault at ffffffff ip b7129ce0 sp bf841060 error 4 in libglib-2.0.so.0.3400.0[b70c6000+129000]
10:59:48,106 NOTICE systemd: NetworkManager.service: main process exited, code=killed, status=11
Comment 12 Chris Lumens 2012-10-15 10:49:00 EDT
This seems to be a dup of both bugs.  How lucky!

*** This bug has been marked as a duplicate of bug 866434 ***

Note You need to log in before you can comment on or make changes to this bug.