This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865100 - katello-configure -reset-db does not reset user password
katello-configure -reset-db does not reset user password
Status: CLOSED DUPLICATE of bug 1125414
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 16:00 EDT by Miroslav Suchý
Modified: 2014-09-04 14:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 14:16:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2012-10-10 16:00:35 EDT
Description of problem:
db user are not updated in second run of katello-configure

Version-Release number of selected component (if applicable):
katello-configure-1.1.10-1.git.93.01b51e4.el6.noarch

How reproducible:
alway

Steps to Reproduce:
1. run: katello-configure -b --db-name=katellodb --db-user=katello --db-password=olletak --deployment=katello
2. katello-configure -b --db-name=katellodb1 --db-user=katello1 --db-password=olletak1 --deployment=katello --reset-data=YES
3. select * from pg_user;
  
Actual results:
  usename  | usesysid | usecreatedb | usesuper | usecatupd |  passwd  | valuntil | useconfig 
-----------+----------+-------------+----------+-----------+----------+----------+-----------
 postgres  |       10 | t           | t        | t         | ******** |          | 
 katello   |    16384 | t           | f        | f         | ******** |          | 
...

Expected results:
I would expect user katello1 created, or if previously such user exist to modify its password or katello-configure to fail with error message.

Additional info:
Comment 2 Bryan Kearney 2014-09-04 14:16:21 EDT
I realize that the older bug should be the duplicate, but the newer one is against  the new installer version. We will track this there.

*** This bug has been marked as a duplicate of bug 1125414 ***

Note You need to log in before you can comment on or make changes to this bug.