Bug 1125414 - Rerunning katello-installer still shows "seed" password even if it has been changed prior
Summary: Rerunning katello-installer still shows "seed" password even if it has been c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 865100 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2014-07-31 18:40 UTC by Corey Welton
Modified: 2019-04-01 20:27 UTC (History)
8 users (show)

Fixed In Version: katello-installer-base-3.0.0.20-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:31:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14254 None None None 2016-04-22 15:36:31 UTC

Description Corey Welton 2014-07-31 18:40:30 UTC
Description of problem:
When user first installs katello, a randomly generated seed password is provided.  If user changes this and subsequently re-runs katello-installer we still display the old, unusable password.

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140730.0

How reproducible:


Steps to Reproduce:
1.  run katello-installer; note the passwd provided, login
2.  change admin passwd
3.  re-run katello-installer

Actual results:
text still displayed indicating the old, non-usable passwd

Expected results:
Something not so confusing

Additional info:

Comment 3 Bryan Kearney 2014-09-04 18:16:21 UTC
*** Bug 865100 has been marked as a duplicate of this bug. ***

Comment 7 Stephen Benjamin 2016-03-17 18:57:27 UTC
Created redmine issue http://projects.theforeman.org/issues/14254 from this bug

Comment 8 Bryan Kearney 2016-04-13 20:11:31 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14254 has been closed
-------------
Anonymous
Applied in changeset commit:katello-installer|a24a179b2fdaca385e890f3d38cf35fbffbd104e.

Comment 9 Kedar Bidarkar 2016-05-24 14:15:34 UTC
admin password is now shown only on first successful install.


VERIFIED with sat62-snap12.1

Comment 10 Bryan Kearney 2016-07-27 11:31:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.