Bug 865302 - tuned-adm Cannot read /var/run/tuned/tuned.pid: [Errno 2] No such file or director - should start
tuned-adm Cannot read /var/run/tuned/tuned.pid: [Errno 2] No such file or dir...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tuned (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
: 858075 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 03:54 EDT by Jan Ščotka
Modified: 2013-03-03 20:30 EST (History)
7 users (show)

See Also:
Fixed In Version: tuned-2.1.0-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:26:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jan Ščotka 2012-10-11 03:58:15 EDT
Hi,
Sorry for noncomplete description :-)

When tuned not running
changing profiles (tuned-adm) causes error
Cannot read /var/run/tuned/tuned.pid: [Errno 2] No such file or directory: '/var/run/tuned/tuned.pid'

I think that command tuned-adm, should shouw better message (for example start tuned, before using tuned-adm)
or start tuned automatically when try to change profile, or other useful thing.
   Regards
   Honza
Comment 2 Jan Kaluža 2012-10-11 04:42:46 EDT
Do you run it as root?
Comment 3 Jan Ščotka 2012-10-11 04:48:54 EDT
Yes I do. I was root
Comment 5 Jaroslav Škarvada 2012-10-11 05:26:55 EDT
For jscotka: probably the same problem, in the test case prereq there is systemctl start tuned.service, so it needs to be run.

For refence 'cat pmtd-selinux-test':
echo -n "AVCs: "
ausearch -m avc -m user_avc -i
setenforce 1
for I in `tuned-adm list | grep "^- " | cut -d ' ' -f 2` ; do
  echo -n > /var/log/audit/audit.log
  tuned-adm active
  echo "* Switching to profile: $I"
  tuned-adm profile $I
  sleep 5
  echo -n "AVCs: "
  ausearch -m avc -m user_avc -i
done
Comment 6 Jan Vcelak 2012-11-07 06:59:48 EST
Resolved upstream, we are switching tuned-adm to DBus. The update is comming soon.
Comment 7 Jan Vcelak 2012-11-07 07:37:34 EST
*** Bug 858075 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-12-03 06:04:51 EST
tuned-2.1.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tuned-2.1.0-1.fc18
Comment 9 Jan Vcelak 2012-12-03 06:10:46 EST
Resolved in:
tuned-2.1.0-1.fc18
tuned-2.1.0-1.fc19
Comment 10 Fedora Update System 2012-12-03 16:33:20 EST
Package tuned-2.1.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tuned-2.1.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19556/tuned-2.1.0-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-12-06 05:32:11 EST
tuned-2.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tuned-2.1.1-1.fc18
Comment 12 Fedora Update System 2013-01-11 20:26:34 EST
tuned-2.1.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.