Bug 865387 - AVC on systemctl start tuned.service
AVC on systemctl start tuned.service
Status: CLOSED DUPLICATE of bug 865443
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 06:21 EDT by Lukas Zachar
Modified: 2012-10-12 05:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 14:00:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zachar 2012-10-11 06:21:30 EDT
Description of problem:
On systemctl start tuned.service I got an AVC:


type=SYSCALL msg=audit(10/11/2012 08:11:58.310:423) : arch=x86_64 syscall=connect success=no exit=-13(Permission denied) a0=0x7 a1=0x7f14506b0390 a2=0x21 a3=0x6e75722f7261762f items=0 ppid=1 pid=6634 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=tuned exe=/usr/bin/python2.7 subj=system_u:system_r:tuned_t:s0 key=(null) 
type=AVC msg=audit(10/11/2012 08:11:58.310:423) : avc:  denied  { search } for  pid=6634 comm=tuned name=dbus dev="tmpfs" ino=14704 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
selinux-policy-3.11.1-35.fc18

How reproducible:
always

Steps to Reproduce:
1. systemctl start tuned.service
2. 
3.
  
Actual results:
AVC

Expected results:
no AVC

Additional info:
Comment 1 Daniel Walsh 2012-10-11 14:00:08 EDT

*** This bug has been marked as a duplicate of bug 865443 ***
Comment 2 Milos Malik 2012-10-12 04:49:24 EDT
Actual results in permissive mode:
----
type=USER_AVC msg=audit(10/12/2012 10:46:38.859:183) : pid=624 uid=dbus auid=unset ses=unset subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_call interface=org.freedesktop.DBus member=Hello dest=org.freedesktop.DBus spid=1422 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=dbus  exe=/usr/bin/dbus-daemon sauid=dbus hostname=? addr=? terminal=?' 
----
type=USER_AVC msg=audit(10/12/2012 10:46:38.865:185) : pid=624 uid=dbus auid=unset ses=unset subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { acquire_svc } for service=com.redhat.tuned spid=1422 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=dbus  exe=/usr/bin/dbus-daemon sauid=dbus hostname=? addr=? terminal=?' 
----
type=PATH msg=audit(10/12/2012 10:46:38.855:182) : item=0 name=(null) inode=16483 dev=00:11 mode=socket,666 ouid=root ogid=root rdev=00:00 obj=system_u:object_r:system_dbusd_var_run_t:s0 
type=SOCKADDR msg=audit(10/12/2012 10:46:38.855:182) : saddr=local /var/run/dbus/system_bus_socket 
type=SYSCALL msg=audit(10/12/2012 10:46:38.855:182) : arch=x86_64 syscall=connect success=yes exit=0 a0=0x7 a1=0x7f1e92418390 a2=0x21 a3=0x6e75722f7261762f items=1 ppid=1421 pid=1423 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=tuned exe=/usr/bin/python2.7 subj=system_u:system_r:tuned_t:s0 key=(null) 
type=AVC msg=audit(10/12/2012 10:46:38.855:182) : avc:  denied  { connectto } for  pid=1423 comm=tuned path=/run/dbus/system_bus_socket scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=unix_stream_socket 
type=AVC msg=audit(10/12/2012 10:46:38.855:182) : avc:  denied  { write } for  pid=1423 comm=tuned name=system_bus_socket dev="tmpfs" ino=16483 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=sock_file 
type=AVC msg=audit(10/12/2012 10:46:38.855:182) : avc:  denied  { search } for  pid=1423 comm=tuned name=dbus dev="tmpfs" ino=16482 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=dir 
----
Comment 3 Miroslav Grepl 2012-10-12 04:59:14 EDT
Ok, it gives us some answers about tuned+dbus.

Note You need to log in before you can comment on or make changes to this bug.