Bug 865443 - SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the directory dbus.
SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the direct...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d19bd55f1535e3b486c24936f86...
:
: 865387 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 09:18 EDT by Jiri Eischmann
Modified: 2012-12-18 15:15 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 14:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-11 09:18 EDT, Jiri Eischmann
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-11 09:18 EDT, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2012-10-11 09:18:30 EDT
Description of problem:
I was trying to start Tuned service via systemd.

Additional info:
libreport version: 2.0.14
kernel:         3.6.1-1.fc18.i686

description:
:SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the directory dbus.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed search access on the dbus directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tuned /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:system_dbusd_var_run_t:s0
:Target Objects                dbus [ dir ]
:Source                        tuned
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-35.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc18.i686 #1 SMP Mon Oct 8
:                              18:03:51 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-10-11 09:13:25 EDT
:Last Seen                     2012-10-11 09:13:25 EDT
:Local ID                      126d3ba5-ad1b-4f1d-a65a-0efda7575926
:
:Raw Audit Messages
:type=AVC msg=audit(1349961205.678:257): avc:  denied  { search } for  pid=1891 comm="tuned" name="dbus" dev="tmpfs" ino=12274 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1349961205.678:257): arch=i386 syscall=socketcall success=no exit=EACCES a0=3 a1=b665edf0 a2=b6ae1ff4 a3=0 items=0 ppid=1 pid=1891 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=tuned exe=/usr/bin/python2.7 subj=system_u:system_r:tuned_t:s0 key=(null)
:
:Hash: tuned,tuned_t,system_dbusd_var_run_t,dir,search
:
:audit2allow
:
:#============= tuned_t ==============
:allow tuned_t system_dbusd_var_run_t:dir search;
:
:audit2allow -R
:
:#============= tuned_t ==============
:allow tuned_t system_dbusd_var_run_t:dir search;
:
Comment 1 Jiri Eischmann 2012-10-11 09:18:34 EDT
Created attachment 625507 [details]
File: type
Comment 2 Jiri Eischmann 2012-10-11 09:18:36 EDT
Created attachment 625508 [details]
File: hashmarkername
Comment 3 Abhay 2012-10-11 12:30:36 EDT
Issues following command from the console:
$ sudo systemctl start tuned.service


Package: (null)
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 4 Daniel Walsh 2012-10-11 13:26:01 EDT
Does tuned use dbus now?
Comment 5 Daniel Walsh 2012-10-11 14:00:09 EDT
*** Bug 865387 has been marked as a duplicate of this bug. ***
Comment 6 Abhay 2012-10-11 22:46:23 EDT
Issued the command from console:
# systemctl start tuned.service


Package: (null)
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 7 Milos Malik 2012-10-12 05:07:28 EDT
This bug should belong to selinux-policy component, right?
Comment 8 Jaroslav Škarvada 2012-10-12 05:17:34 EDT
(In reply to comment #4)
> Does tuned use dbus now?

Yes, it uses dbus.
Comment 9 Jaroslav Škarvada 2012-10-12 05:18:53 EDT
(In reply to comment #7)
> This bug should belong to selinux-policy component, right?

Probably, reassigning.
Comment 10 Daniel Walsh 2012-10-12 06:14:52 EDT
rpm -ql tuned| grep dbus
/etc/dbus-1/system.d/com.redhat.tuned.conf
/usr/lib/python2.7/site-packages/tuned/exports/dbus.py
/usr/lib/python2.7/site-packages/tuned/exports/dbus.pyc
/usr/lib/python2.7/site-packages/tuned/exports/dbus.pyo


Looks like it uses dbus.

Fixed in selinux-policy-3.11.1-38.fc18.noarch
Comment 11 Fedora Update System 2012-10-23 16:34:15 EDT
selinux-policy-3.11.1-43.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-43.fc18
Comment 12 Fedora Update System 2012-10-26 11:37:11 EDT
selinux-policy-3.11.1-46.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-46.fc18
Comment 13 Fedora Update System 2012-10-26 15:26:33 EDT
Package selinux-policy-3.11.1-46.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-46.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16862/selinux-policy-3.11.1-46.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.