Bug 865404 - Cannot add a Group to tomcat6's UserDatabase
Cannot add a Group to tomcat6's UserDatabase
Status: CLOSED DUPLICATE of bug 865460
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Tomcat (Show other bugs)
JON 3.1.1
Unspecified Unspecified
high Severity high
: ---
: JON 3.1.2
Assigned To: Jean-frederic Clere
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 07:12 EDT by Jan Martiska
Modified: 2014-06-20 12:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 04:06:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2012-10-11 07:12:09 EDT
Tomcat version: EWS 2.0.0.CR1

When I try to add a User Group through JON's interface, I get this error in agent's log:

2012-10-11 06:51:52,901 DEBUG [ResourceFactory.executor-1] (rhq.core.pc.inventory.CreateResourceRunner)- Throwable was found in creation report for request [10041].
java.lang.IllegalStateException: Name [roles] specified for parameter of operation [createGroup] on MBean [Users:type=UserDatabase,database=UserDatabase] is invalid. The MBean operation does not take a parameter by that name.
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:576)
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:524)
	at org.jboss.on.plugins.tomcat.TomcatUserDatabaseComponent.createResource(TomcatUserDatabaseComponent.java:68)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:634)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Comment 1 Misha H. Ali 2012-10-14 21:01:50 EDT
Possible duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=865460
Comment 2 mark yarborough 2012-11-12 15:22:30 EST
This bug needs a corresponding bug in Jira or Bz (as appropriate) owned by the plugin team. Mark Yarborough work with John Doyle to define EWS owner.
Comment 3 Michal Haško 2013-01-08 04:06:52 EST

*** This bug has been marked as a duplicate of bug 865460 ***

Note You need to log in before you can comment on or make changes to this bug.