Bug 865460 - Cannot add a Group to tomcat's UserDatabase
Cannot add a Group to tomcat's UserDatabase
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: JON Plugin (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 2.0.1
Assigned To: Jean-frederic Clere
Mike Foley
:
: 865404 (view as bug list)
Depends On:
Blocks: 956987 956990
  Show dependency treegraph
 
Reported: 2012-10-11 09:38 EDT by Jan Martiska
Modified: 2014-08-08 00:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to missing parameters a public class, adding a group to Tomcat's <classname>UserDatabase</classname> using the JBoss Operations Network (JON) interface displays an error: <screen>DEBUG [ResourceFactory.executor-1] (rhq.core.pc.inventory.CreateResourceRunner)- Throwable was found in creation report for request [10083]. java.lang.IllegalStateException: Name [roles] specified for parameter of operation [createGroup] on MBean [Users:type=UserDatabase,database=UserDatabase] is invalid. The MBean operation does not take a parameter by that name..</screen> A fix is applied to add the missing parameters. As a result, adding a group to Tomcat's <classname>UserDatabase</classname> works as expected in JBoss Enterprise Web Server 2.0.1.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 07:59:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2012-10-11 09:38:25 EDT
Tomcat7 version: EWS 2.0.0.CR1

When I try to add a User Group through JON's interface, I get this error in agent's log:

2012-10-11 09:35:28,596 DEBUG [ResourceFactory.executor-1] (rhq.core.pc.inventory.CreateResourceRunner)- Throwable was found in creation report for request [10083].
java.lang.IllegalStateException: Name [roles] specified for parameter of operation [createGroup] on MBean [Users:type=UserDatabase,database=UserDatabase] is invalid. The MBean operation does not take a parameter by that name.
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:576)
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:524)
	at org.jboss.on.plugins.tomcat.TomcatUserDatabaseComponent.createResource(TomcatUserDatabaseComponent.java:68)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:634)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Comment 1 Misha H. Ali 2012-10-14 21:01:39 EDT
Duplicate bug: https://bugzilla.redhat.com/show_bug.cgi?id=865460
Comment 2 mark yarborough 2012-11-12 15:22:37 EST
This bug needs a corresponding bug in Jira or Bz (as appropriate) owned by the plugin team. Mark Yarborough work with John Doyle to define EWS owner.
Comment 3 Michal Haško 2013-01-08 04:05:52 EST
This issue affects all tomcat{5,6,7} versions.
Comment 4 Michal Haško 2013-01-08 04:06:52 EST
*** Bug 865404 has been marked as a duplicate of this bug. ***
Comment 7 Libor Fuka 2013-05-10 08:48:47 EDT
Verified with Tomcat plugin brew build [1] and EWS 2.0.1.ER1
[1] https://brewweb.devel.redhat.com//buildinfo?buildID=269954
Comment 8 Mandar Joshi 2013-05-14 02:31:15 EDT
Added DocText.

@Wei Nan Li, can you please review the Doc Text content?
Comment 9 Mandar Joshi 2013-05-14 02:48:41 EDT
oops..

@Jean-Frederic Clere,  can you please review the Doc Text content?
Comment 10 Jean-frederic Clere 2013-05-14 05:05:34 EDT
See BZ 688358 they are duplicated.

Note You need to log in before you can comment on or make changes to this bug.