This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865459 - Cannot add a User to tomcat's UserDatabase
Cannot add a User to tomcat's UserDatabase
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: JON Plugin (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 2.0.1
Assigned To: Jean-frederic Clere
Mike Foley
:
: 865403 (view as bug list)
Depends On:
Blocks: 956987 956990
  Show dependency treegraph
 
Reported: 2012-10-11 09:38 EDT by Jan Martiska
Modified: 2014-08-08 00:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to missing parameters in the public class, adding a user to Tomcat's <classname>UserDatabase</classname> using the JBoss Operations Network (JON) interface in JBoss Enterprise Web Server displays an error in agent's log indicating that the MBean parameters are invalid. A fix is applied to add the missing parameters. As a result, adding users to Tomcat's <classname>UserDatabase</classname> using JBoss Operations Network (JON) works as expected in JBoss Operations Network (JON).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 07:58:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Avoid operation error (1.74 KB, patch)
2012-11-29 13:11 EST, Remy Maucherat
no flags Details | Diff

  None (edit)
Description Jan Martiska 2012-10-11 09:38:23 EDT
Tomcat7 version: EWS 2.0.0.CR1

When I try to add a User through JON's interface, I get this error in agent's log:

2012-10-11 09:35:03,828 DEBUG [ResourceFactory.executor-1] (rhq.core.pc.inventory.CreateResourceRunner)- Throwable was found in creation report for request [10082].
java.lang.IllegalStateException: Name [roles] specified for parameter of operation [createUser] on MBean [Users:type=UserDatabase,database=UserDatabase] is invalid. The MBean operation does not take a parameter by that name.
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:576)
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:524)
	at org.jboss.on.plugins.tomcat.TomcatUserDatabaseComponent.createResource(TomcatUserDatabaseComponent.java:68)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:634)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Comment 1 mark yarborough 2012-11-12 15:22:33 EST
This bug needs a corresponding bug in Jira or Bz (as appropriate) owned by the plugin team. Mark Yarborough work with John Doyle to define EWS owner.
Comment 2 Remy Maucherat 2012-11-29 13:11:54 EST
Created attachment 654435 [details]
Avoid operation error

Avoid the error due to the missing parameters on the operation. Any roles or groups must be added later.
Comment 3 Michal Haško 2013-01-08 04:03:54 EST
This issue affects all tomcat{5,6,7} versions.
Comment 4 Michal Haško 2013-01-08 04:04:12 EST
*** Bug 865403 has been marked as a duplicate of this bug. ***
Comment 7 Libor Fuka 2013-05-10 08:49:06 EDT
Verified with Tomcat plugin brew build [1] and EWS 2.0.1.ER1
[1] https://brewweb.devel.redhat.com//buildinfo?buildID=269954
Comment 8 Mandar Joshi 2013-05-14 02:33:42 EDT
Added DocText.

@Wei Nan Li, can you please review the Doc Text content?
Comment 9 Mandar Joshi 2013-05-14 02:47:40 EDT
oops..

@Jean-Frederic Clere,  can you please review the Doc Text content?
Comment 10 Jean-frederic Clere 2013-05-14 05:04:26 EDT
See BZ 688358 they are duplicated.
Comment 11 Jean-frederic Clere 2013-06-14 04:50:29 EDT
That is nice to have the details for the fix in the release notices but are you sure the customers need that.
See BZ 865460
Comment 12 Misha H. Ali 2013-06-14 05:17:12 EDT
Jean-Frederic, ideally all the release notes should have this much detail where possible. Unfortunately this is not possible sometimes without SME additions. For consistency, I have reduced the detail to match other similar bugs.

Note You need to log in before you can comment on or make changes to this bug.