Bug 865671 - changing the input type from the panel isn't applied permenently
changing the input type from the panel isn't applied permenently
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
: 870015 895463 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 01:38 EDT by Akira TAGOH
Modified: 2013-02-18 20:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 20:26:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-10-12 01:38:51 EDT
Description of problem:
once switching to other source, the changes of the input type from panel is lost.

Version-Release number of selected component (if applicable):
ibus-anthy-1.4.99.20121006-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1.change the input type to Kana from the panel
2.switch to other source
3.switch to anthy and see the input type
  
Actual results:
the input type gets back to Romaji

Expected results:
the input type should be Kana

Additional info:
Comment 1 fujiwara 2012-10-19 07:24:46 EDT
Since ibus engines are switched between ibus input method and xkb keymaps, probably I think each engine needs to keep the global status.

The following is the tentative fix.
https://github.com/fujiwarat/ibus-anthy/commit/d104cbc66f338fd24143379a3424426c25def122
Comment 2 Mike FABIAN 2012-10-20 07:51:22 EDT
Very nice! Reading fujiwara’s patch made me understand how
I could fix the same problem in ibus-typing-booster:

http://git.fedorahosted.org/cgit/ibus-typing-booster.git/commit/?id=f6de75c50b9fe9574f47b575da186832c0d7e6eb
Comment 3 fujiwara 2012-10-25 21:11:42 EDT
*** Bug 870015 has been marked as a duplicate of this bug. ***
Comment 4 fujiwara 2013-01-16 05:19:01 EST
*** Bug 895463 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-01-16 05:35:01 EST
ibus-1.5.1-1.fc18, ibus-anthy-1.5.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.0-1.fc18,ibus-1.5.1-1.fc18
Comment 6 Fedora Update System 2013-01-16 05:36:47 EST
ibus-1.5.1-1.fc17, ibus-anthy-1.5.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-anthy-1.5.0-1.fc17,ibus-1.5.1-1.fc17
Comment 7 Fedora Update System 2013-01-18 15:25:06 EST
Package ibus-1.5.1-1.fc18, ibus-anthy-1.5.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.1-1.fc18 ibus-anthy-1.5.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0911/ibus-anthy-1.5.0-1.fc18,ibus-1.5.1-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-18 20:26:15 EST
ibus-anthy-1.5.0-1.fc17, ibus-1.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-02-18 20:30:45 EST
ibus-anthy-1.5.0-1.fc18, ibus-1.5.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.