Bug 870015 - Sometimes both hiragana mode *and* katakana are selected in the ibus-anthy menu in the gnome panel
Sometimes both hiragana mode *and* katakana are selected in the ibus-anthy me...
Status: CLOSED DUPLICATE of bug 865671
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 07:33 EDT by Mike FABIAN
Modified: 2012-10-25 21:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 21:11:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots-1-2-3-ibus-anthy-input-mode-switching-problem.png (903.24 KB, image/png)
2012-10-25 07:34 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2012-10-25 07:33:35 EDT
Tested on: Fedora-18-Beta-TC6-x86_64-netinst.iso
ibus-anthy version: ibus-anthy-1.4.99.20121006-1.fc18.x86_64

Steps to reproduce:

- After installation in Japanese, log in to Gnome.
- Select the Anthy input method  in the Gnome panel
- Open the “入力モード(あ)” menu of Anthy in the input method
  menu in the Gnome panel
- Now one can see a white bullet in front of ひらがな
  which means hiragana input mode is selected, which is the default.

  → see screenshot 1.
  
- In the menu, click on 地域と言語の設定 (region and language settings)
- Select the tab 入力ソース (input sources)
- Select the 日本語 (Anthy) input method.
- Click on the icon with the wrench and the screwdriver at the bottom
  to open the setup tool for Anthy.
- Switch the 入力モード to カタカナ (switch the input mode to katakana)
- Click on 適用 (apply) at the bottom.

  → see screenshot 2.

  Now a popup says:

      Anthy キーボードレイアウトが変更されました。レイアウトを再読み込みするため
      に ibus を再起動してください。

                                                           [ OK(O) ]

  (By the way, maybe it is not nice that there is no way to restart
  ibus from the menu now as in f17, one needs to use the command line,
  maybe not every user knows how to restart ibus from the command line)

- Click OK to close the popup
- Click OK to close the Anthy setup
- Close the region and language settings dialog.
- Switch input method to “en” (英語(US)), i.e. US English keyboard
- type “ibus restart” in a terminal
- Switch input method to 日本語 (Anthy) again in the panel
- Now a ア appears in the panel, indicating that katakana input mode
  is used as requested above in the setting.
- type something in the terminal to verify that katakana appears
- Click on the input method selector in the panel again, in
  the menu which opens, open the “入力モード(ア)” menu of Anthy
- Now one can see that *both* ひらがな *and* カタカナ have a white
  bullet in front

  → see screenshot 3.

  This is the bug.

- try to select hiragana input again by clicking on ひらがな in the menu.
- type something, the input mode is still katakana

Workaround to switch to Hiragana:

- Click on one of the other input modes except ひらがな and カタカナ,
  for example 半角カタカナ. Now the panel shows

    _ア

  I.e. it was possible to select 半角カタカナ mode.
- type something to verify that the input is really in
  半角カタカナ mode.
- Open the input method menu in the panel again.
- Open the 入力モード(_ア) menu again.
- Now one can see that there is a white bullet *only* in
  front of 半角カタカナ
- Now it is possible to switch back to ひらがな input mode.
Comment 1 Mike FABIAN 2012-10-25 07:34:50 EDT
Created attachment 633275 [details]
screenshots-1-2-3-ibus-anthy-input-mode-switching-problem.png

The 3 screenshots mentioned in comment#0.
Comment 2 fujiwara 2012-10-25 21:11:42 EDT

*** This bug has been marked as a duplicate of bug 865671 ***
Comment 3 fujiwara 2012-10-25 21:15:06 EDT
Workaround: click both menu items and clear the radio status.

Note You need to log in before you can comment on or make changes to this bug.